View Issue Details

IDProjectCategoryView StatusLast Update
0018656LazarusLCLpublic2019-12-12 11:37
ReporterDenis GottardelloAssigned ToAbou Al Montacir 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target Version0.9.31 (SVN)Fixed in Version0.9.31 (SVN) 
Summary0018656: debian package: Unit non found: "RegisterLCL"
DescriptionOn start lazarus from svn (01.02.2011, debian package) I obtain this popup message:
Package: "LCLBase 1.0"
Unit name: "RegisterLCL"

Unit non found: "RegisterLCL"

Apparently some lpk files are missing in the deb.
Additional Informationroot@debian01:~# lazarus-ide
TLazarusManager.Run starting /usr/lib/lazarus/0.9.31/lazarus ...
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/root/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
NOTE: editor options config file not found - using defaults
Nota: non è stato trovato il file configurazione codetools - uso i valori predefiniti
invalid Package Link: file "/usr/lib/lazarus/0.9.31/lcl/lclbase.lpk" does not exist.
invalid Package Link: file "/usr/lib/lazarus/0.9.31/lcl/interfaces/lcl.lpk" does not exist.
TLazPackageGraph.RegistrationError Package: "LCLBase 1.0"#0DNome unit: "RegisterLCL"#0D#0DUnit non trovata: "RegisterLCL"
TagsNo tags attached.
Fixed in Revision30381
LazTarget0.99.0
Widgetset
Attached Files

Activities

Abou Al Montacir

2011-02-02 11:13

developer   ~0045704

Can you please give me the result of the following commands ?
LANG=C update-alternatives --display lazarus
LANG=C update-alternatives --display lazarus-ide

Hans Luijten

2011-02-03 07:24

reporter   ~0045733

Last edited: 2011-02-03 07:27

I'm running into the same problem.

Lazarus/FPC seems to be able to create a simple app (empty form) without a problem after clicking "ignore", lazreport 0.9.8 however refuses to install (/usr/lib/lazarus/0.9.31/ide/lazarus.pp(1,1) Fatal: Can't find unit lazreport used by Lazarus -- not sure if it is relevant)

OS: Ubuntu 10.10 desktop, Lazarus 0.9.31 nightly build (20110201).
Requested output on my machine (hope this helps):

hans@ubuntu:~$ LANG=C update-alternatives --display lazarus
lazarus - auto mode
  link currently points to /usr/lib/lazarus/0.9.31
/usr/lib/lazarus/0.9.31 - priority 20
  slave lazarus.cfg: /etc/lazarus-0.9.31
  slave lazbuild: /usr/lib/lazarus/0.9.31/lazbuild
  slave lazbuild.1.gz: /usr/share/man/man1/lazbuild-0.9.31.1.gz
  slave lazres: /usr/lib/lazarus/0.9.31/tools/lazres
  slave lazres.1.gz: /usr/share/man/man1/lazres-0.9.31.1.gz
  slave lrstolfm: /usr/lib/lazarus/0.9.31/tools/lrstolfm
  slave lrstolfm.1.gz: /usr/share/man/man1/lrstolfm-0.9.31.1.gz
  slave svn2revisioninc: /usr/lib/lazarus/0.9.31/tools/svn2revisioninc
  slave svn2revisioninc.1.gz: /usr/share/man/man1/svn2revisioninc-0.9.31.1.gz
  slave updatepofiles: /usr/lib/lazarus/0.9.31/tools/updatepofiles
  slave updatepofiles.1.gz: /usr/share/man/man1/updatepofiles-0.9.31.1.gz
Current 'best' version is '/usr/lib/lazarus/0.9.31'.


hans@ubuntu:~$ LANG=C update-alternatives --display lazarus-ide
lazarus-ide - auto mode
  link currently points to /usr/lib/lazarus/0.9.31/startlazarus
/usr/lib/lazarus/0.9.31/startlazarus - priority 20
  slave lazarus.xpm: /usr/share/pixmaps/lazarus-0.9.31.xpm
  slave startlazarus: /usr/lib/lazarus/0.9.31/startlazarus
Current 'best' version is '/usr/lib/lazarus/0.9.31/startlazarus'.
hans@ubuntu:~$

Denis Gottardello

2011-02-07 09:43

reporter   ~0045862

root@debian01:/home/denis/Download/lazarus-0.9.31.29368-20110204.i386.deb# LANG=C update-alternatives --display lazarus
lazarus - auto mode
  link currently points to /usr/lib/lazarus/0.9.31
/usr/lib/lazarus/0.9.31 - priority 20
  slave lazarus.cfg: /etc/lazarus-0.9.31
  slave lazbuild: /usr/lib/lazarus/0.9.31/lazbuild
  slave lazbuild.1.gz: /usr/share/man/man1/lazbuild-0.9.31.1.gz
  slave lazres: /usr/lib/lazarus/0.9.31/tools/lazres
  slave lazres.1.gz: /usr/share/man/man1/lazres-0.9.31.1.gz
  slave lrstolfm: /usr/lib/lazarus/0.9.31/tools/lrstolfm
  slave lrstolfm.1.gz: /usr/share/man/man1/lrstolfm-0.9.31.1.gz
  slave svn2revisioninc: /usr/lib/lazarus/0.9.31/tools/svn2revisioninc
  slave svn2revisioninc.1.gz: /usr/share/man/man1/svn2revisioninc-0.9.31.1.gz
  slave updatepofiles: /usr/lib/lazarus/0.9.31/tools/updatepofiles
  slave updatepofiles.1.gz: /usr/share/man/man1/updatepofiles-0.9.31.1.gz
Current 'best' version is '/usr/lib/lazarus/0.9.31'.
root@debian01:/home/denis/Download/lazarus-0.9.31.29368-20110204.i386.deb#


root@debian01:/home/denis/Download/lazarus-0.9.31.29368-20110204.i386.deb# LANG=C update-alternatives --display lazarus-ide
lazarus-ide - auto mode
  link currently points to /usr/lib/lazarus/0.9.31/startlazarus
/usr/lib/lazarus/0.9.31/startlazarus - priority 20
  slave lazarus.xpm: /usr/share/pixmaps/lazarus-0.9.31.xpm
  slave startlazarus: /usr/lib/lazarus/0.9.31/startlazarus
Current 'best' version is '/usr/lib/lazarus/0.9.31/startlazarus'.
root@debian01:/home/denis/Download/lazarus-0.9.31.29368-20110204.i386.deb#


Now I'm using version 28842 (20101231) that works very vell.

Abou Al Montacir

2011-02-08 11:14

developer   ~0045892

Last edited: 2011-02-13 09:39

Hans,

Can you pleased test with latest snapshot and confirm this is working?

Denis Gottardello

2011-02-17 16:31

reporter   ~0046114

No, does not work.

Marelis

2011-04-12 13:05

reporter   ~0047441

The same problem also with snapshot deb's rev.30268 and 'make deb' with svn source rev.30269, OS Ubuntu 10.10 i386.

Bad luck, I just wanted to go back to the development of the Lazarus IDE and how to watch as debian packages are again "patients". Anyone Know which debian package's revision is still usable?

Marelis

2011-04-13 07:03

reporter   ~0047447

How do you want your users to test the Lazarus IDE, when is faulty installation of Debian packages? Two months of no reaction, and this issue is marked as minor. I'm amazed.

Vincent Snijders

2011-04-13 09:35

manager   ~0047451

@Marelis, if the users cannot test with the debs, they can test with the sources or even with rpms.

Of course this issue is major for you.

Mattias Gaertner

2011-04-13 11:08

manager   ~0047453

The tool tools/lplupdate.lpi shows what lpk files are missing in the debian packages:

Dead link lazwebextra-0.9 to missing $(LazarusDir)/components/fpweb/lazwebextra.lpk
Dead link lazmouseandkeyinput-0.1 to missing $(LazarusDir)/components/mouseandkeyinput/lazmouseandkeyinput.lpk
Dead link lcl-1.0.1 to missing $(LazarusDir)/lcl/interfaces/lcl.lpk
Dead link externhelp-1.3 to missing $(LazarusDir)/components/externhelp/externhelp.lpk
Dead link lazdbexport-1 to missing $(LazarusDir)/components/dbexport/lazdbexport.lpk
Dead link macosfiles-0 to missing $(LazarusDir)/components/macfiles/macosfiles.lpk
Dead link idefilebrowser-0.2 to missing $(LazarusDir)/components/filebrowser/idefilebrowser.lpk
Dead link h2paswizard-0 to missing $(LazarusDir)/components/h2pas/h2paswizard.lpk
Dead link lazcustforms-1 to missing $(LazarusDir)/components/customform/lazcustforms.lpk
Dead link simpleideintf-0 to missing $(LazarusDir)/components/simpleideintf/simpleideintf.lpk
Dead link lazparadox-0 to missing $(LazarusDir)/components/paradox/lazparadox.lpk
Dead link lazdaemon-0.9.9 to missing $(LazarusDir)/components/daemon/lazdaemon.lpk
Dead link lazplotfunction-0.0.1 to missing $(LazarusDir)/components/plotfunction/lazplotfunction.lpk
Dead link ide-0 to missing $(LazarusDir)/ide/ide.lpk
Dead link aggpaslcl-1 to missing $(LazarusDir)/components/aggpas/lazarus/aggpaslcl.lpk
Dead link weblaz-0 to missing $(LazarusDir)/components/fpweb/weblaz.lpk
Dead link customdrawn-0 to missing $(LazarusDir)/components/customdrawn/customdrawn.lpk
Dead link lazopenglcontext-0.0.1 to missing $(LazarusDir)/components/opengl/lazopenglcontext.lpk
Dead link imagesforlazarus-1.0.1 to missing $(LazarusDir)/components/images/imagesforlazarus.lpk
Dead link lclbase-1.0.1 to missing $(LazarusDir)/lcl/lclbase.lpk
Dead link synuni-1 to missing $(LazarusDir)/components/synunihighlighter/synuni.lpk
Dead link educationlaz-1.0.1 to missing $(LazarusDir)/components/education/educationlaz.lpk
Dead link lazthread-0 to missing $(LazarusDir)/components/lazthread/lazthread.lpk
Dead link rx-1 to missing $(LazarusDir)/components/rx/rx.lpk
Dead link lazsvnpkg-0.0.1 to missing $(LazarusDir)/components/lazsvnpkg/lazsvnpkg.lpk
Dead link editortoolbar-0.4 to missing $(LazarusDir)/components/editortoolbar/editortoolbar.lpk
Dead link leakview-1 to missing $(LazarusDir)/components/leakview/leakview.lpk
Dead link lazdatadict-0 to missing $(LazarusDir)/components/datadict/lazdatadict.lpk
Dead link ideinspector-0.1 to missing $(LazarusDir)/components/IdeInspector/ideinspector.lpk
Dead link cocoa_pkg-0 to missing $(LazarusDir)/lcl/interfaces/carbon/pascocoa/cocoa_pkg.lpk
Dead link messagecomposerpkg-0 to missing $(LazarusDir)/components/messagecomposer/messagecomposerpkg.lpk
Dead link appforms-1 to missing $(LazarusDir)/components/customform/demo/appforms.lpk
Dead link prettymessages-0 to missing $(LazarusDir)/components/prettymessages/prettymessages.lpk
Dead link lazc-0.1 to missing $(LazarusDir)/components/compilers/c/lazc.lpk

Marelis

2011-04-27 10:36

reporter   ~0047829

Last edited: 2011-04-27 10:36

@Vincent
That I was the only one who wants to use the Debian packages with Lazarus IDE ?

@Mattias
Awesome, finally someone solves little! Phase 1: "What has gone wrong" is behind us. And going to the Phase 2: "we fix it" ?

@Abou Al Montacir
Man, do you live ?

I used the method of "Wag the Dog" and switched from Ubuntu to openSUSE :o)

It reminds me of a humorous character of our country (Czech Republic): Jára Cimrman.

Good luck!

Abou Al Montacir

2011-05-10 13:29

developer   ~0048187

Sorry being late, but I was busy for other things.

Now, Debian packages are mainly supported on official Debian repository for official releases. On these official versions, response time is very short and the stability is a main target.

For snapshots, these are supported as developer versions, and are targeting people who can workaround bugs themselves. You can not expect stable packages nor short reaction. I don't recoomend you to use them for production software. And either you provide a patch or you wait.

I'm really sorry that you changed distribution from Debian to another vendor, and hope you will realize the need to have a stable SW soon or late.

Cheers,

Marelis

2011-05-11 04:11

reporter   ~0048206

Great!

Ubuntu 11.04 + FPC 2.4.2 + Lazarus IDE svn 30669 + 'make deb' = It works

I went back to Ubuntu, even when they try using the 'Unity' on it to make colorful LEGO for young children. In the openSUSE are problems with the FPC and make command to create a cross compiler for Win64.

OT: It is almost desperate, as the old version of FPC and Lazarus IDE are available in the repositories of Linux distributions. And those low-numbered versions leads to the illusion that this is a beginner's project (or dying). Perhaps it will ever change.

Thank you for your repair of Debian packages!

Denis Gottardello

2011-05-18 10:19

reporter   ~0048369

I'm sorry but lazarus-deb 30303, 20110416 has the same iussue on Debian Squeeze i386.

Abou Al Montacir

2011-05-18 10:35

developer   ~0048370

Normal since the fix was on 30381 and you are using 30303. Can you please try with newer version?

Denis Gottardello

2011-05-18 14:43

reporter   ~0048375

In the snapshots I find only the 30381 deb package. Do you know why?

Marelis

2011-05-19 14:54

reporter   ~0048413

Snapshots somehow freeze ... probably all gone ;)

Denis Gottardello

2011-05-20 12:24

reporter   ~0048438

Ok. I will wait the updated Debian package of Lazarus.

Denis Gottardello

2011-05-24 14:05

reporter   ~0048545

Ok, now works well.

Issue History

Date Modified Username Field Change
2011-02-01 14:50 Denis Gottardello New Issue
2011-02-01 14:50 Denis Gottardello Widgetset => GTK 2
2011-02-01 16:24 Vincent Snijders LazTarget => 0.99.0
2011-02-01 16:24 Vincent Snijders Assigned To => Abou Al Montacir
2011-02-01 16:24 Vincent Snijders Status new => assigned
2011-02-01 16:24 Vincent Snijders Target Version => 0.99.0
2011-02-01 17:35 Mattias Gaertner Summary Unit non finded: "RegisterLCL" => debian package: Unit non found: "RegisterLCL"
2011-02-01 17:35 Mattias Gaertner Description Updated
2011-02-02 11:13 Abou Al Montacir Note Added: 0045704
2011-02-02 11:13 Abou Al Montacir Status assigned => feedback
2011-02-03 07:24 Hans Luijten Note Added: 0045733
2011-02-03 07:27 Hans Luijten Note Edited: 0045733
2011-02-07 09:43 Denis Gottardello Note Added: 0045862
2011-02-08 11:14 Abou Al Montacir Note Added: 0045892
2011-02-13 09:39 Abou Al Montacir Note Edited: 0045892
2011-02-17 16:31 Denis Gottardello Note Added: 0046114
2011-03-14 18:41 Abou Al Montacir Status feedback => assigned
2011-04-12 13:05 Marelis Note Added: 0047441
2011-04-13 07:03 Marelis Note Added: 0047447
2011-04-13 09:35 Vincent Snijders Note Added: 0047451
2011-04-13 11:08 Mattias Gaertner Note Added: 0047453
2011-04-27 10:36 Marelis Note Added: 0047829
2011-04-27 10:36 Marelis Note Edited: 0047829
2011-05-10 13:29 Abou Al Montacir Fixed in Revision => 30381
2011-05-10 13:29 Abou Al Montacir Widgetset GTK 2 =>
2011-05-10 13:29 Abou Al Montacir Status assigned => resolved
2011-05-10 13:29 Abou Al Montacir Fixed in Version => 0.9.31 (SVN)
2011-05-10 13:29 Abou Al Montacir Resolution open => fixed
2011-05-10 13:29 Abou Al Montacir Note Added: 0048187
2011-05-10 13:29 Abou Al Montacir Target Version 0.99.0 => 0.9.31 (SVN)
2011-05-11 04:11 Marelis Note Added: 0048206
2011-05-18 10:19 Denis Gottardello Status resolved => assigned
2011-05-18 10:19 Denis Gottardello Resolution fixed => reopened
2011-05-18 10:19 Denis Gottardello Note Added: 0048369
2011-05-18 10:35 Abou Al Montacir Note Added: 0048370
2011-05-18 10:35 Abou Al Montacir Status assigned => feedback
2011-05-18 14:43 Denis Gottardello Note Added: 0048375
2011-05-19 14:54 Marelis Note Added: 0048413
2011-05-20 12:24 Denis Gottardello Note Added: 0048438
2011-05-24 14:05 Denis Gottardello Note Added: 0048545
2011-05-24 22:36 Vincent Snijders Status feedback => resolved
2011-05-24 22:36 Vincent Snijders Resolution reopened => fixed