View Issue Details

IDProjectCategoryView StatusLast Update
0018671LazarusLCLpublic2011-10-08 02:47
ReporterVáclav Dort Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version0.9.31 (SVN) 
Summary0018671: Buttons are not tab focusable.
DescriptionOn Mac OS buttons are not tab focusable.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCarbon
Attached Files

Activities

Juha Manninen

2011-02-02 16:57

developer   ~0045722

Which buttons?

Phil

2011-02-02 17:22

reporter   ~0045723

On Mac, tabbing is supposed to skip over controls that cannot receive the keyboard focus, such as buttons, combos, check boxes, radio groups, list boxes, etc. You can set TabStop = False for these controls to skip over them and also to eliminate the Console warning that you get since LCL doesn't support the logic needed to skip these and tries to focus them anyway.

More here:

http://web.me.com/macpgmr/ObjP/MacXPlatform_Part8.html#Dialogs

Dmitry Boyarintsev

2011-10-08 02:47

developer   ~0052763

this is mac default behavior

Issue History

Date Modified Username Field Change
2011-02-02 15:02 Václav Dort New Issue
2011-02-02 15:02 Václav Dort Widgetset => Carbon
2011-02-02 16:57 Juha Manninen Note Added: 0045722
2011-02-02 17:22 Phil Note Added: 0045723
2011-02-09 21:39 Vincent Snijders LazTarget => -
2011-02-09 21:39 Vincent Snijders Assigned To => Dmitry Boyarintsev
2011-02-09 21:39 Vincent Snijders Status new => assigned
2011-10-08 02:47 Dmitry Boyarintsev Status assigned => resolved
2011-10-08 02:47 Dmitry Boyarintsev Resolution open => no change required
2011-10-08 02:47 Dmitry Boyarintsev Note Added: 0052763