View Issue Details

IDProjectCategoryView StatusLast Update
0018708LazarusLCLpublic2011-12-01 11:26
ReporterHans LuijtenAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version 
Summary0018708: TPrintDialog causes error: pgCopies.Caption: Unknown property: "Caption"
DescriptionWhen calling TPrintDialog.Execute the following error appears:
pgCopies.Caption: Unknown property: "Caption".

Application runs correctly otherwise, compiles just fine as well.

Noticed in the mailinglist that others run into this issue as well, but one of the reporters it appears to happen on his desktop, but not his laptop (which he claims are the same Lazarus setup).

I tried the daily snapshots (a few weeks old), and I completely reinstalled Ubuntu, installed FPC 2.4.2, verified and fixed dependencies, then installed subversion and Lazarus from SVN. Problem remains. Used "svn update" two days later; problem remains.

I have 2 printers installed (Epson and HP), I can print a test page outside of Lazarus.
Additional InformationUbuntu 10.10 Desktop, Intel 32 bit, Daily Snapshot (mid January) and SVN 0.9.31 of 2011-02-05, FPC 2.4.2
TagsNo tags attached.
Fixed in Revision
LazTarget0.99.0
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0018587 closedFelipe Monteiro de Carvalho printerdialog.execute return error on runtime 

Activities

2011-02-07 20:01

 

PrintDialogErrorSample.zip (2,422 bytes)

Vincent Snijders

2011-02-10 23:29

manager   ~0045949

Wasn't this reported in another issue too?

Vincent Snijders

2011-02-10 23:52

manager   ~0045952

Resolved as duplicate.

Issue History

Date Modified Username Field Change
2011-02-07 19:55 Hans Luijten New Issue
2011-02-07 19:55 Hans Luijten Widgetset => GTK 2
2011-02-07 20:01 Hans Luijten File Added: PrintDialogErrorSample.zip
2011-02-10 23:29 Vincent Snijders LazTarget => 0.99.0
2011-02-10 23:29 Vincent Snijders Assigned To => Felipe Monteiro de Carvalho
2011-02-10 23:29 Vincent Snijders Status new => acknowledged
2011-02-10 23:29 Vincent Snijders Target Version => 0.99.0
2011-02-10 23:29 Vincent Snijders Note Added: 0045949
2011-02-10 23:29 Vincent Snijders Status acknowledged => assigned
2011-02-10 23:31 Vincent Snijders Relationship added duplicate of 0018587
2011-02-10 23:52 Vincent Snijders Status assigned => resolved
2011-02-10 23:52 Vincent Snijders Resolution open => duplicate
2011-02-10 23:52 Vincent Snijders Note Added: 0045952
2011-12-01 11:26 Marc Weustink Status resolved => closed