View Issue Details

IDProjectCategoryView StatusLast Update
0018736Lazarus-public2011-02-13 12:34
ReporterBurkhard CarstensAssigned ToVincent Snijders 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSlinuxOS Versionsuse 10.0
Product Version0.9.31 (SVN)Product Build29471 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0018736: rev29258 breaks make all for non-debian
Descriptionclean svn checkout on suse 10.2

make all

Makefile:3601: *** Need "lazarus_0.9.31.orig.tar.gz" to build for DEBBUILD = "" > 1. Schluss.
Makefile:3601: *** Need "lazarus_0.9.31.orig.tar.gz" to build for DEBBUILD = "" > 1. Schluss.

"svn up Makefile.* -r29257" fixes this
TagsNo tags attached.
Fixed in Revision29472
LazTarget-
Widgetset
Attached Files
  • git.diff (1,674 bytes)
    diff --git a/Makefile b/Makefile
    index dbe22ea..2b34682 100644
    --- a/Makefile
    +++ b/Makefile
    @@ -3596,18 +3596,17 @@ endif
     ifdef SNAPSHOT
     DEBUSESVN=1
     endif
    -ifeq ($(wildcard ${DEBSRC_ORIG}.tar.gz),)
    -ifndef DEBUSESVN
    -$(error Need "${DEBSRC_ORIG}.tar.gz" to build for DEBBUILD = "${DEBBUILD}" > 1)
    -endif
    -endif
     ifndef SIGN
     DEB_BUILDPKG_OPT+= -us -uc
     endif
     debcheck:
     ifneq ($(DEBVERSION),$(PACKAGE_VERSION))
    -	@$(ECHO) "Debian version ($(DEBVERSION)) is not correct, expect $(PACKAGE_VERSION)"
    -	@exit 1
    +	! ${ECHO} "Debian version ($(DEBVERSION)) is not correct, expect $(PACKAGE_VERSION)"
    +endif
    +ifeq ($(wildcard ${DEBSRC_ORIG}.tar.gz),)
    +ifndef DEBUSESVN
    +	! ${ECHO} 'Need "${DEBSRC_ORIG}.tar.gz" to build for DEBBUILD = "${DEBBUILD}" > 1'
    +endif
     endif
     debcopy: distclean
     	${DELTREE} ${BUILDDIR}
    diff --git a/Makefile.fpc b/Makefile.fpc
    index dd5bad2..180028c 100644
    --- a/Makefile.fpc
    +++ b/Makefile.fpc
    @@ -192,19 +192,18 @@ endif
     ifdef SNAPSHOT
     DEBUSESVN=1
     endif
    -ifeq ($(wildcard ${DEBSRC_ORIG}.tar.gz),)
    -ifndef DEBUSESVN
    -$(error Need "${DEBSRC_ORIG}.tar.gz" to build for DEBBUILD = "${DEBBUILD}" > 1)
    -endif
    -endif
     ifndef SIGN
     DEB_BUILDPKG_OPT+= -us -uc
     endif
     
     debcheck:
     ifneq ($(DEBVERSION),$(PACKAGE_VERSION))
    -	@$(ECHO) "Debian version ($(DEBVERSION)) is not correct, expect $(PACKAGE_VERSION)"
    -	@exit 1
    +	! ${ECHO} "Debian version ($(DEBVERSION)) is not correct, expect $(PACKAGE_VERSION)"
    +endif
    +ifeq ($(wildcard ${DEBSRC_ORIG}.tar.gz),)
    +ifndef DEBUSESVN
    +	! ${ECHO} 'Need "${DEBSRC_ORIG}.tar.gz" to build for DEBBUILD = "${DEBBUILD}" > 1'
    +endif
     endif
     
     debcopy: distclean
    
    git.diff (1,674 bytes)

Activities

Burkhard Carstens

2011-02-11 20:58

reporter   ~0045978

it's actually "svn up Makefile* -r29257" (without dot after Makefile) to fixes this.

2011-02-11 22:10

 

git.diff (1,674 bytes)
diff --git a/Makefile b/Makefile
index dbe22ea..2b34682 100644
--- a/Makefile
+++ b/Makefile
@@ -3596,18 +3596,17 @@ endif
 ifdef SNAPSHOT
 DEBUSESVN=1
 endif
-ifeq ($(wildcard ${DEBSRC_ORIG}.tar.gz),)
-ifndef DEBUSESVN
-$(error Need "${DEBSRC_ORIG}.tar.gz" to build for DEBBUILD = "${DEBBUILD}" > 1)
-endif
-endif
 ifndef SIGN
 DEB_BUILDPKG_OPT+= -us -uc
 endif
 debcheck:
 ifneq ($(DEBVERSION),$(PACKAGE_VERSION))
-	@$(ECHO) "Debian version ($(DEBVERSION)) is not correct, expect $(PACKAGE_VERSION)"
-	@exit 1
+	! ${ECHO} "Debian version ($(DEBVERSION)) is not correct, expect $(PACKAGE_VERSION)"
+endif
+ifeq ($(wildcard ${DEBSRC_ORIG}.tar.gz),)
+ifndef DEBUSESVN
+	! ${ECHO} 'Need "${DEBSRC_ORIG}.tar.gz" to build for DEBBUILD = "${DEBBUILD}" > 1'
+endif
 endif
 debcopy: distclean
 	${DELTREE} ${BUILDDIR}
diff --git a/Makefile.fpc b/Makefile.fpc
index dd5bad2..180028c 100644
--- a/Makefile.fpc
+++ b/Makefile.fpc
@@ -192,19 +192,18 @@ endif
 ifdef SNAPSHOT
 DEBUSESVN=1
 endif
-ifeq ($(wildcard ${DEBSRC_ORIG}.tar.gz),)
-ifndef DEBUSESVN
-$(error Need "${DEBSRC_ORIG}.tar.gz" to build for DEBBUILD = "${DEBBUILD}" > 1)
-endif
-endif
 ifndef SIGN
 DEB_BUILDPKG_OPT+= -us -uc
 endif
 
 debcheck:
 ifneq ($(DEBVERSION),$(PACKAGE_VERSION))
-	@$(ECHO) "Debian version ($(DEBVERSION)) is not correct, expect $(PACKAGE_VERSION)"
-	@exit 1
+	! ${ECHO} "Debian version ($(DEBVERSION)) is not correct, expect $(PACKAGE_VERSION)"
+endif
+ifeq ($(wildcard ${DEBSRC_ORIG}.tar.gz),)
+ifndef DEBUSESVN
+	! ${ECHO} 'Need "${DEBSRC_ORIG}.tar.gz" to build for DEBBUILD = "${DEBBUILD}" > 1'
+endif
 endif
 
 debcopy: distclean
git.diff (1,674 bytes)

Vincent Snijders

2011-02-11 22:16

manager   ~0045982

Can you try attached patch?

Burkhard Carstens

2011-02-11 22:43

reporter   ~0045983

This solves the problem.

Vincent Snijders

2011-02-11 22:54

manager   ~0045984

Fixed by patch from mazen.

Burkhard Carstens

2011-02-13 09:44

reporter   ~0046009

fix confirmed. thanks.

Issue History

Date Modified Username Field Change
2011-02-11 20:54 Burkhard Carstens New Issue
2011-02-11 20:58 Burkhard Carstens Note Added: 0045978
2011-02-11 22:10 Vincent Snijders File Added: git.diff
2011-02-11 22:16 Vincent Snijders LazTarget => -
2011-02-11 22:16 Vincent Snijders Note Added: 0045982
2011-02-11 22:16 Vincent Snijders Status new => feedback
2011-02-11 22:43 Burkhard Carstens Note Added: 0045983
2011-02-11 22:54 Vincent Snijders Fixed in Revision => 29472
2011-02-11 22:54 Vincent Snijders Status feedback => resolved
2011-02-11 22:54 Vincent Snijders Fixed in Version => 0.9.31 (SVN)
2011-02-11 22:54 Vincent Snijders Resolution open => fixed
2011-02-11 22:54 Vincent Snijders Assigned To => Vincent Snijders
2011-02-11 22:54 Vincent Snijders Note Added: 0045984
2011-02-13 09:44 Burkhard Carstens Status resolved => closed
2011-02-13 09:44 Burkhard Carstens Note Added: 0046009
2011-02-13 12:34 Vincent Snijders Fixed in Version 0.9.31 (SVN) => 0.9.29 (SVN)