View Issue Details

IDProjectCategoryView StatusLast Update
0018795LazarusIDEpublic2012-02-16 16:58
ReporterMichael Van CanneytAssigned ToZeljan Rikalo 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGTK2OSLinuxOS Version
Product Version0.9.31 (SVN)Product Build 
Target Version1.0.0Fixed in Version 
Summary0018795: GetEditorControlSettings is buggy
DescriptionThe SQL editor dialog is supposed to have the same font as the source editor.
However, it has a smaller font (to the point of being unreadable)
Steps To Reproduce1. Drop TSQLQuery (from sqldblaz) on a form/datamodule
2. Edit the SQL property.
-> The font in the SQL property dialog is smaller than the source editor font.
(see attached image)
Additional InformationSee attached screenshot
TagsNo tags attached.
Fixed in Revision35401
LazTarget1.0
WidgetsetGTK 2
Attached Files

Relationships

related to 0017694 resolvedMartin Friebe Changing font size problem 

Activities

2011-02-21 17:03

 

font.png (12,413 bytes)
font.png (12,413 bytes)

Zeljan Rikalo

2011-04-04 09:28

developer   ~0047179

Last edited: 2011-04-04 09:29

Look screenshots of my gtk2 behaviour.1st shows editor settings, another shows sql editor.
Lazarus 0.9.31 r30166M FPC 2.4.3 i386-linux-gtk 2, Fedora 14.

2011-04-04 09:28

 

editorfont.png (83,819 bytes)
editorfont.png (83,819 bytes)

2011-04-04 09:29

 

sqleditorfont.png (16,828 bytes)
sqleditorfont.png (16,828 bytes)

2011-09-08 16:10

 

font-settings.png (84,118 bytes)
font-settings.png (84,118 bytes)

2011-09-08 16:10

 

font-sql-editor.png (101,312 bytes)
font-sql-editor.png (101,312 bytes)

Michael Van Canneyt

2011-09-08 16:12

administrator   ~0051609

I can only show my font settings (font-settings.png) and the actual settings in the windows: font-sql-editor.png.

The editor font and SQL strings property dialog editor are clearly different fonts.

Lazarus version 32114M, linux GTK, Ubuntu 10.04, 64-bit

Zeljan Rikalo

2011-10-30 21:16

developer   ~0053656

We should stop use of X11 old names for fonts. Such naming was ok before fontconfig (in times of xfs), now it's obsoleted, and does not have any sense.
That's why it works for me, I'm using simple font names which are understandable by font config.

Juha Manninen

2011-11-17 14:06

developer   ~0054150

Interesting.
With default configuration, when built for GTK2 bindings, Lazarus editor font setting is:
  -misc-dejavu sans mono-medium-r-normal-*-*-90-*-*-*-*-iso10646-1

But built for QT bindings:
  DejaVu Sans Mono

cobines

2011-11-17 17:29

reporter   ~0054158

This is set in synedit.pp InitSynDefaultFont.

Zeljan Rikalo

2011-11-17 17:57

developer   ~0054162

One more time: we should change that, so gtk2 (and any other except gtk) shouldn't use raw X11 font names, but family names (using fontconfig).

Juha Manninen

2011-11-17 18:58

developer   ~0054166

I changed it in r33591. Please test.

Michael, does it solve the problem if you use the short raw font name?

Zeljan Rikalo

2011-11-17 19:45

developer   ~0054168

@Juha "raw" means X11 naming :) , 2nd thing is that gtk2 still uses "raw" font names in many cases (font.name combobox in oi, enumfontfamilies etc etc) which need to be fixed and consistent.

Zeljan Rikalo

2012-02-06 20:10

developer   ~0056596

I guess that this won't be ready for 1.0

Zeljan Rikalo

2012-02-16 16:58

developer   ~0056860

Please test and close if ok.

Issue History

Date Modified Username Field Change
2011-02-21 17:03 Michael Van Canneyt New Issue
2011-02-21 17:03 Michael Van Canneyt File Added: font.png
2011-02-21 17:03 Michael Van Canneyt LazTarget => -
2011-02-21 17:03 Michael Van Canneyt Widgetset => GTK 2
2011-02-21 17:03 Michael Van Canneyt Relationship added related to 0017694
2011-03-30 22:31 Vincent Snijders LazTarget - => 1.0
2011-03-30 22:31 Vincent Snijders Status new => acknowledged
2011-04-04 09:28 Zeljan Rikalo Note Added: 0047179
2011-04-04 09:28 Zeljan Rikalo Status acknowledged => feedback
2011-04-04 09:28 Zeljan Rikalo File Added: editorfont.png
2011-04-04 09:29 Zeljan Rikalo File Added: sqleditorfont.png
2011-04-04 09:29 Zeljan Rikalo Note Edited: 0047179
2011-09-08 16:10 Michael Van Canneyt File Added: font-settings.png
2011-09-08 16:10 Michael Van Canneyt File Added: font-sql-editor.png
2011-09-08 16:12 Michael Van Canneyt Note Added: 0051609
2011-10-30 21:16 Zeljan Rikalo Note Added: 0053656
2011-11-17 14:06 Juha Manninen Note Added: 0054150
2011-11-17 17:29 cobines Note Added: 0054158
2011-11-17 17:57 Zeljan Rikalo Note Added: 0054162
2011-11-17 18:58 Juha Manninen Note Added: 0054166
2011-11-17 19:45 Zeljan Rikalo Note Added: 0054168
2011-11-18 13:38 Juha Manninen Status feedback => assigned
2011-11-18 13:38 Juha Manninen Assigned To => Juha Manninen
2012-02-06 20:10 Zeljan Rikalo Note Added: 0056596
2012-02-13 16:40 Juha Manninen Assigned To Juha Manninen => Zeljan Rikalo
2012-02-16 16:58 Zeljan Rikalo Fixed in Revision => 35401
2012-02-16 16:58 Zeljan Rikalo Status assigned => resolved
2012-02-16 16:58 Zeljan Rikalo Resolution open => fixed
2012-02-16 16:58 Zeljan Rikalo Note Added: 0056860