View Issue Details

IDProjectCategoryView StatusLast Update
0018834LazarusDebuggerpublic2011-04-24 10:07
ReporterdolpatAssigned ToMartin Friebe 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0018834: CPU Register window --- Show all registers in hexadecimal
DescriptionIn View | Debugging windows | Registers:
 Only registers BP, SP and IP values are displayed in hexadecimal.

Would be a good idea to display all registers primarily in hexadecimal and decimal numbers between brackets. This would give for the decimal value 100:
 0x64 (100)

This would greatly simplify the debugging operations because currently, I am constantly forced to manually convert the values ...

Thank you
TagsNo tags attached.
Fixed in Revision30434
LazTarget0.99.0
WidgetsetWin32/Win64
Attached Files

Activities

Martin Friebe

2011-04-23 16:07

manager   ~0047711

Default format was left as is currently.

Added an option to change the format for any register. Select some or all register, and change the format.

Please close if ok.

Issue History

Date Modified Username Field Change
2011-02-27 10:11 dolpat New Issue
2011-02-27 10:11 dolpat Widgetset => Win32/Win64
2011-03-30 22:35 Vincent Snijders LazTarget => -
2011-03-30 22:35 Vincent Snijders Assigned To => Martin Friebe
2011-03-30 22:35 Vincent Snijders Status new => assigned
2011-03-30 22:35 Vincent Snijders Category IDE => Debugger
2011-04-23 16:07 Martin Friebe Fixed in Revision => 30434
2011-04-23 16:07 Martin Friebe LazTarget - => 0.99.0
2011-04-23 16:07 Martin Friebe Status assigned => resolved
2011-04-23 16:07 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2011-04-23 16:07 Martin Friebe Resolution open => fixed
2011-04-23 16:07 Martin Friebe Note Added: 0047711
2011-04-23 16:07 Martin Friebe Target Version => 0.99.0
2011-04-24 10:07 dolpat Status resolved => closed