View Issue Details

IDProjectCategoryView StatusLast Update
0018839LazarusIDEpublic2011-10-08 04:48
ReporterTheCreativeCAT Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN) 
Summary0018839: Height and width of TLabel become one in intel Mac
DescriptionSome TLabels defined in the Lazarus for PPC Mac disappear in the Lazarus for intel Mac because their height and width are forced to 1.
Additional InformationThis fault occurs when a TLabel has both

1. non-default font and/or size properties
2. Autosize Property : True (default).

I wrote a sample project under a PPC mac. Please download the attached file, LabelSizeTest.zip, which contains a project and two screenshots. As you can see in PPC.tiff, the project has five TLabels on Form1 with following properties, from top to bottom:

(1) default font, default size, autosize = true
(2) default font, size = 20, autosize = true
(3) font = Areal, default size, autosize = true
(4) font = Areal, size = 20, autosize = true
(5) font = Areal, size = 20, autosize = false

However, when loaded in an intel Mac, the third and fourth label disappear (i386.tiff). The width and height properties of both labels are fixed to 1 and never been changed. This is bothering even there is a simple workaround: use default font/size or turn off autosize.

The SVN for PPC Lazarus is 29691, running under Mac OS X 10.5.8 and intel Lazarus has a SVN version of 29672, running under Mac OS X 10.6.6.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCarbon
Attached Files

Activities

2011-02-28 07:35

 

LabelSizeTest.zip (178,579 bytes)

TheCreativeCAT

2011-02-28 07:42

reporter   ~0046305

Sorry, I have confused. I wrote;

"This fault occurs when a TLabel has both

1. non-default font and/or size properties
2. Autosize Property : True (default)."

Here, 1. is incorrect. It must be:

1'. non-default font property.

Also,

"This is bothering even there is a simple workaround: use default font/size or turn off autosize."

must be;

"This is bothering even there is a simple workaround: use default font or turn off autosize."

because this problem does not occur with the default font (the second label in the example).

Dmitry Boyarintsev

2011-10-08 04:47

developer   ~0052768

the issue seems to be fixed -r 32684.
please retest and close if confirmed.

Issue History

Date Modified Username Field Change
2011-02-28 07:35 TheCreativeCAT New Issue
2011-02-28 07:35 TheCreativeCAT File Added: LabelSizeTest.zip
2011-02-28 07:35 TheCreativeCAT Widgetset => Carbon
2011-02-28 07:42 TheCreativeCAT Note Added: 0046305
2011-03-02 02:09 Dmitry Boyarintsev Status new => assigned
2011-03-02 02:09 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2011-10-08 04:47 Dmitry Boyarintsev LazTarget => -
2011-10-08 04:47 Dmitry Boyarintsev Status assigned => resolved
2011-10-08 04:47 Dmitry Boyarintsev Resolution open => fixed
2011-10-08 04:47 Dmitry Boyarintsev Note Added: 0052768