View Issue Details

IDProjectCategoryView StatusLast Update
0018848LazarusIDEpublic2014-10-09 15:31
ReporterChristianAssigned ToJuha Manninen 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target Version1.4Fixed in Version 
Summary0018848: IDE Removes ImageLists
DescriptionWhen u use Imagelists that are located on another Form or Datamodule and open The Form without the other Form or Datamodule is open the ide removes the Imagelist from any Control who it is assigned and saves also the form so.
TagsNo tags attached.
Fixed in Revision
LazTarget1.4
Widgetset
Attached Files

Relationships

related to 0008484 resolvedJesus Reyes Actions doesn't propagate icons to SpeedButtons or BitBtns in some situations for example if ImageList is in a TDataModule 

Activities

Zeljan Rikalo

2012-02-04 13:44

developer   ~0056412

Not blocker, postponed.

Christian

2012-02-04 13:48

reporter   ~0056416

Lazarus removes Propertys from Forms, this dont blocks 1.0?
Sry i dont understand that when i havend open my Datamodule with Global Imagelist and i Open an Form Lazarus removes Imagelist Property from all Cntrols that have an Imagelist. For me that is a Blocker and importand for 1.0 !!!

Mike Thompson

2014-09-21 22:31

developer   ~0077507

<looks carefully for OS/Widgetset... :)>

Tested under Lazarus 1.3/win32/SVN45863 & Lazarus1.2.4/gtk2/Win 7. Unable to reproduce. (closed and reopened Lazarus ensuring DataModule wasn't open on close)

(Belated note to Christian: I suspect this was deemed a non-blocker as you could always link the imagelist in code...)

Juha Manninen

2014-09-22 10:38

developer   ~0077517

Fixed in the meantime.

Christian

2014-09-22 18:17

reporter   ~0077544

no its not fixed :)
But iam only able to reproduce it in my real world application at time not in an small sample project but i till try to find the step to reproduce it

Mike Thompson

2014-09-22 18:35

developer   ~0077545

Last edited: 2014-09-23 14:54

View 3 revisions

@Christian - Thanks for the info. What lazarus version did you do your test with?

UPDATE: Just a thought - is your TDataModule in the project, or is it in a package used by the project? (I didn't test that scenario)

Juha Manninen

2014-09-25 15:48

developer   ~0077647

Christian, would you please answer the questions. We are waiting...

Juha Manninen

2014-10-09 15:31

developer   ~0078099

No feedback from reporter.
Presumably fixed in trunk.

Issue History

Date Modified Username Field Change
2011-03-01 07:45 Christian New Issue
2011-03-30 22:37 Vincent Snijders LazTarget => 1.0
2011-03-30 22:37 Vincent Snijders Status new => acknowledged
2011-03-30 22:37 Vincent Snijders Target Version => 1.0.0
2012-02-04 13:44 Zeljan Rikalo LazTarget 1.0 => 1.2
2012-02-04 13:44 Zeljan Rikalo Note Added: 0056412
2012-02-04 13:48 Christian Note Added: 0056416
2012-02-12 14:29 Juha Manninen Relationship added related to 0008484
2012-03-13 07:50 Vincent Snijders Target Version 1.0.0 => 1.2.0
2014-01-14 15:10 Martin Friebe LazTarget 1.2 => 1.4
2014-01-14 15:12 Martin Friebe Target Version 1.2.0 => 1.4
2014-09-21 22:31 Mike Thompson Note Added: 0077507
2014-09-22 10:38 Juha Manninen Note Added: 0077517
2014-09-22 10:38 Juha Manninen Status acknowledged => resolved
2014-09-22 10:38 Juha Manninen Resolution open => fixed
2014-09-22 10:38 Juha Manninen Assigned To => Juha Manninen
2014-09-22 18:17 Christian Note Added: 0077544
2014-09-22 18:17 Christian Status resolved => assigned
2014-09-22 18:17 Christian Resolution fixed => reopened
2014-09-22 18:35 Mike Thompson Note Added: 0077545
2014-09-22 18:50 Juha Manninen Status assigned => feedback
2014-09-23 14:53 Mike Thompson Note Edited: 0077545 View Revisions
2014-09-23 14:54 Mike Thompson Note Edited: 0077545 View Revisions
2014-09-25 15:48 Juha Manninen Note Added: 0077647
2014-10-09 15:31 Juha Manninen Note Added: 0078099
2014-10-09 15:31 Juha Manninen Status feedback => resolved
2014-10-09 15:31 Juha Manninen Resolution reopened => fixed