View Issue Details

IDProjectCategoryView StatusLast Update
0018862LazarusLCLpublic2011-06-23 05:42
ReporterChristianAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0018862: SynEdit only works with Application instance created by Forms
DescriptionIts a bit ugly issue,
Synedit creats an SynDefaultBeautifier in his initialization section
Forms creates TApplication in his initialization Section

since i have some additions to TApplication i free the instance of TApplication created by Forms in my main project unit and cerate an own. But until now Synedit and everything its used by (at example Lazreport ...) dosend work correct becouse SynDefaultBeautifier has an invalid Owner. SynDefaultBeautifier shouldnt be cerated in the initialization of synedit i think its better to create it in .Create of TSynEdit.
Also its ugly that Forms creates the instance of TApplication in my opinion this should be done in the Main Unit
Example:

  Application := TApplication.Create(nil);
  Application.Initialize;
  Application.CreateForm(TfMain, fMain);
  Application.Run;

But i see that this would break delphi compatibility.
TagsNo tags attached.
Fixed in Revision30008
LazTarget0.99.0
Widgetset
Attached Files

Activities

Martin Friebe

2011-03-24 22:27

manager   ~0046803

I changed it, because I had some long standing todo in source-edtitor, that needed to deal with the side-effects of a single instance default beautifier.

Replacing the Application instance should not be a reason to disallow application usage in initialization. The order of initialization can be controlled, so the correct application should be available during initialization too.

Issue History

Date Modified Username Field Change
2011-03-03 11:40 Christian New Issue
2011-03-04 20:12 Martin Friebe Status new => assigned
2011-03-04 20:12 Martin Friebe Assigned To => Martin Friebe
2011-03-24 22:27 Martin Friebe Fixed in Revision => 30008
2011-03-24 22:27 Martin Friebe LazTarget => 0.99.0
2011-03-24 22:27 Martin Friebe Status assigned => resolved
2011-03-24 22:27 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2011-03-24 22:27 Martin Friebe Resolution open => fixed
2011-03-24 22:27 Martin Friebe Note Added: 0046803
2011-06-23 05:42 Christian Status resolved => closed