View Issue Details

IDProjectCategoryView StatusLast Update
0018908LazarusLCLpublic2017-04-23 12:38
ReporterRoland TurcanAssigned ToDmitry Boyarintsev 
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionunable to reproduce 
PlatformOSXOSOSXOS Version
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version 
Summary0018908: Access violation on MAC
DescriptionOften happens, that application raises an exception on checkboxes or radiobuttons, ... and the stack point to menu stuff. This is stack of exception which happens when form if being opened.

Lazarus revision 29766

3/11/11 10:33:24 AM [0x0-0x38c38c].com.company.rotursoft[56583] TApplication.HandleException
3/11/11 10:33:24 AM [0x0-0x38c38c].com.company.rotursoft[56583] Access violation
3/11/11 10:33:24 AM [0x0-0x38c38c].com.company.rotursoft[56583] Stack trace:
3/11/11 10:33:24 AM [0x0-0x38c38c].com.company.rotursoft[56583] $005EA3B3
3/11/11 10:33:24 AM [0x0-0x38c38c].com.company.rotursoft[56583] $00705204 TCARBONMENU__SETENABLE, line 576 of /Users/test/develop/lazarus/lcl/interfaces/./carbon/carbonmenus.pp
3/11/11 10:33:24 AM [0x0-0x38c38c].com.company.rotursoft[56583] $006BF97F TCARBONWIDGETSET__SETMAINMENUENABLED, line 561 of /Users/test/develop/lazarus/lcl
3/11/11 10:33:24 AM [0x0-0x38c38c].com.company.rotursoft[56583] /interfaces/./carbon/carbonint.pas
3/11/11 10:33:24 AM [0x0-0x38c38c].com.company.rotursoft[56583] $0070125E TCARBONWINDOW__CLOSEMODAL, line 1757 of /Users/test/develop/lazarus/lcl/interfaces/./carbon/carbonprivate.pp
3/11/11 10:33:24 AM [0x0-0x38c38c].com.company.rotursoft[56583] $00735DBF TCARBONWSCUSTOMFORM__CLOSEMODAL, line 192 of /Users/test/develop/lazarus/lcl/interfa
3/11/11 10:33:25 AM [0x0-0x38c38c].com.company.rotursoft[56583] ces/./carbon/carbonwsforms.pp
3/11/11 10:33:25 AM [0x0-0x38c38c].com.company.rotursoft[56583] $00030677 TCUSTOMFORM__SHOWMODAL, line 2693 of /Users/test/develop/lazarus/lcl/forms.pp
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCarbon
Attached Files

Activities

Vincent Snijders

2011-03-30 22:44

manager   ~0046980

Can you provide an example application?

Roland Turcan

2011-04-06 16:36

reporter   ~0047283

Not really, because it doesn't happen always, it comes as surprise.

Here is another stack from r.29960

#0 CLASSES_TLIST_$__INDEXOF$POINTER$$LONGINT at :0
0000001 CONTNRS_TOBJECTLIST_$__INDEXOF$TOBJECT$$LONGINT at :0
0000002 TCARBONMENU__SETENABLE(false, (TCARBONMENU) 0x2019c9e0) at ./carbon/carbonmenus.pp:586
0000003 TCARBONWIDGETSET__SETMAINMENUENABLED(false, (TCARBONWIDGETSET) 0x9560360) at ./carbon/carbonlclintf.inc:561
0000004 TCARBONWINDOW__SHOWMODAL((TCARBONWINDOW) 0x20a2dce0) at ./carbon/carbonprivatewindow.inc:1791
0000005 TCARBONWSCUSTOMFORM__SHOWMODAL((^TCUSTOMFORM) 0x2031b070, (pvmt) 0x971fea0) at ./carbon/carbonwsforms.pp:205
0000006 TCUSTOMFORM__SHOWMODAL((TCUSTOMFORM) 0x2031b070) at ./include/customform.inc:2665

Dmitry Boyarintsev

2011-04-14 03:15

developer   ~0047467

are you trying to close modal window by changing checkbox or radiobutton value?

Roland Turcan

2011-04-18 10:18

reporter   ~0047547

No this happens usually when going over *box.

Reinier Olislagers

2014-09-22 12:50

developer   ~0077522

Filled in OSX due to mentioned Carbon widgetset.

Can somebody with OSX confirm this is still an issue?

Karl-Michael Schindler

2014-09-27 13:19

reporter   ~0077732

I tried a new project with one form and 3 radio buttons and 3 checkboxes and did not get any crashes. So, leave it open, but remove the target?

Juha Manninen

2017-04-23 12:38

developer   ~0099805

Resolving as "unable to reproduce". Please reopen if you still get access violation with Lazarus trunk or fixes_1_8 branch.

Issue History

Date Modified Username Field Change
2011-03-11 11:05 Roland Turcan New Issue
2011-03-11 11:05 Roland Turcan Widgetset => Carbon
2011-03-30 22:43 Vincent Snijders LazTarget => 1.0
2011-03-30 22:43 Vincent Snijders Assigned To => Dmitry Boyarintsev
2011-03-30 22:43 Vincent Snijders Status new => assigned
2011-03-30 22:43 Vincent Snijders Target Version => 1.0.0
2011-03-30 22:44 Vincent Snijders Note Added: 0046980
2011-03-30 22:44 Vincent Snijders Status assigned => feedback
2011-04-06 16:36 Roland Turcan Note Added: 0047283
2011-04-14 03:15 Dmitry Boyarintsev Note Added: 0047467
2011-04-18 10:18 Roland Turcan Note Added: 0047547
2011-10-10 12:07 Vincent Snijders LazTarget 1.0 => 1.2
2011-10-10 12:07 Vincent Snijders Target Version 1.0.0 => 1.2.0
2012-03-13 18:28 Vincent Snijders Status feedback => assigned
2014-01-14 15:10 Martin Friebe LazTarget 1.2 => 1.4
2014-01-14 15:12 Martin Friebe Target Version 1.2.0 => 1.4
2014-09-22 12:50 Reinier Olislagers Note Added: 0077522
2014-09-22 12:50 Reinier Olislagers OS => OSX
2014-09-22 12:50 Reinier Olislagers Platform => OSX
2014-09-27 13:19 Karl-Michael Schindler Note Added: 0077732
2015-04-27 21:59 Juha Manninen LazTarget 1.4 => -
2015-04-27 22:02 Juha Manninen Target Version 1.4 =>
2017-04-23 12:38 Juha Manninen Note Added: 0099805
2017-04-23 12:38 Juha Manninen Status assigned => resolved
2017-04-23 12:38 Juha Manninen Resolution open => unable to reproduce