View Issue Details

IDProjectCategoryView StatusLast Update
0018924LazarusIDEpublic2011-03-15 23:28
ReporterJohn RepucciAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0018924: Automatically increase Build Number does not increase via Ctrl-F9
DescriptionThe build number --does-- increment when going through the menu - Run > Build, but it --does not-- increment when I use the Ctrl-F9 (Build hotkey) or F9 (Build if necessary, then Run hotkey).
Expected behavior: it should increment if a Ctrl-F9 or F9 is selected.

Also, the build number does not increment if a build is performed as part of a menu - Run > Run selection.
Expected behavior: If a build is done, the build number should increment.
Additional InformationWin32, Vista, 0.9.31-29747, 2.4.2
TagsNo tags attached.
Fixed in Revision29845
LazTarget-
Widgetset
Attached Files

Relationships

has duplicate 0017622 closedMaxim Ganetsky Automatically increase build number not working if Build or Run 

Activities

John Repucci

2011-03-15 00:36

reporter   ~0046609

correction:
Build number works via: Menu: Run > Build All

Does not work via Run > Build, or the rest as mentioned above.

Paul Ishenin

2011-03-15 01:02

manager   ~0046610

There was a wrong caption for Ctrl+F9 - it mean not build all the files but only changed. In other IDEs it has "Compile" caption. I changed that - so there will be no further misleading. I also mapped Shift + F9 to the Build command. Try it - it will increase a version number.

Please close if ok.

John Repucci

2011-03-15 23:28

reporter   ~0046628

Confirmed; Build via Shift-F9 does increment the build number.
(note: if Run requires a build, the build number should increment as well, but that is a topic for another day.)
Thank you!

Issue History

Date Modified Username Field Change
2011-03-14 22:37 John Repucci New Issue
2011-03-14 22:37 John Repucci Widgetset => Win32/Win64
2011-03-15 00:36 John Repucci Note Added: 0046609
2011-03-15 00:59 Maxim Ganetsky LazTarget => -
2011-03-15 00:59 Maxim Ganetsky Widgetset Win32/Win64 =>
2011-03-15 00:59 Maxim Ganetsky Relationship added duplicate of 0017622
2011-03-15 00:59 Maxim Ganetsky Duplicate ID 0 => 17622
2011-03-15 00:59 Maxim Ganetsky Status new => resolved
2011-03-15 00:59 Maxim Ganetsky Resolution open => fixed
2011-03-15 00:59 Maxim Ganetsky Assigned To => Maxim Ganetsky
2011-03-15 01:00 Maxim Ganetsky Resolution fixed => duplicate
2011-03-15 01:02 Paul Ishenin Fixed in Revision => 29845
2011-03-15 01:02 Paul Ishenin Note Added: 0046610
2011-03-15 01:02 Paul Ishenin Duplicate ID 17622 => 0
2011-03-15 01:02 Paul Ishenin Resolution duplicate => fixed
2011-03-15 01:02 Paul Ishenin Fixed in Version => 0.9.31 (SVN)
2011-03-15 01:04 Maxim Ganetsky Assigned To Maxim Ganetsky => Paul Ishenin
2011-03-15 01:05 Maxim Ganetsky Relationship deleted 0017622
2011-03-15 23:28 John Repucci Status resolved => closed
2011-03-15 23:28 John Repucci Note Added: 0046628
2011-03-16 00:57 Maxim Ganetsky Relationship added has duplicate 0017622