View Issue Details

IDProjectCategoryView StatusLast Update
0018948LazarusIDEpublic2013-05-31 08:02
ReporterCao Yang Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platformx86_32OSWindows7 64bit 
Target Version1.2.0 
Summary0018948: Nearly every hint text in the IDE doesn't work properly
DescriptionJust as the screenshots.
TagsNo tags attached.
Fixed in Revision
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0022851 resolvedPaul Ishenin Hint for component on component palette is not completely visible 
related to 0019117 closedMattias Gaertner Declaration hints displayed at the top of editor window are cut off 

Activities

2011-03-19 09:46

 

screenshot.png (26,995 bytes)   
screenshot.png (26,995 bytes)   

Vincent Snijders

2011-03-30 22:58

manager   ~0046983

A difference between the expected font metrics and the actual font metrics?

Zeljan Rikalo

2011-04-04 08:24

developer   ~0047164

Is this win32 or what ?

Cao Yang

2011-04-07 05:39

reporter   ~0047301

Both win32 and win64 can not work properly.

samuel herzog

2011-10-30 08:46

developer   ~0053620

Looks ok here with Lazarus 0.9.31 r FPC 2.5.1 i386-win32-win32/win64 on win xp sp3.

Juha Manninen

2011-11-18 14:28

developer   ~0054201

Is this a High DPI issue?
My hints look OK on Windows 7.

Zeljan Rikalo

2012-02-04 13:45

developer   ~0056414

Not blocker, postponed.

Juha Manninen

2013-05-31 08:02

developer   ~0067947

Resolving as duplicate.

Issue History

Date Modified Username Field Change
2011-03-19 09:46 Cao Yang New Issue
2011-03-19 09:46 Cao Yang File Added: screenshot.png
2011-03-19 10:42 Florian Project FPC => Lazarus
2011-03-30 22:58 Vincent Snijders LazTarget => 1.0
2011-03-30 22:58 Vincent Snijders Note Added: 0046983
2011-03-30 22:58 Vincent Snijders Status new => acknowledged
2011-03-30 22:58 Vincent Snijders Target Version => 1.0.0
2011-04-04 08:24 Zeljan Rikalo Note Added: 0047164
2011-04-04 08:24 Zeljan Rikalo Status acknowledged => feedback
2011-04-07 05:39 Cao Yang Note Added: 0047301
2011-04-07 15:28 Paul Ishenin Relationship added related to 0019117
2011-10-10 12:06 Vincent Snijders Status feedback => acknowledged
2011-10-10 12:06 Vincent Snijders Widgetset => Win32/Win64
2011-10-30 08:46 samuel herzog Note Added: 0053620
2011-11-18 14:28 Juha Manninen Note Added: 0054201
2011-11-18 14:28 Juha Manninen Status acknowledged => feedback
2012-02-04 13:45 Zeljan Rikalo LazTarget 1.0 => 1.2
2012-02-04 13:45 Zeljan Rikalo Note Added: 0056414
2012-03-13 07:50 Vincent Snijders Target Version 1.0.0 => 1.2.0
2012-09-10 21:06 Juha Manninen Relationship added has duplicate 0022851
2013-05-31 08:02 Juha Manninen Note Added: 0067947
2013-05-31 08:02 Juha Manninen Relationship replaced duplicate of 0022851
2013-05-31 08:02 Juha Manninen Status feedback => resolved
2013-05-31 08:02 Juha Manninen Resolution open => duplicate
2013-05-31 08:02 Juha Manninen Assigned To => Juha Manninen