View Issue Details

IDProjectCategoryView StatusLast Update
0018949Packages-public2011-10-03 15:46
ReporterAvishai Assigned ToVincent Snijders  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN) 
Summary0018949: TPanel.Caption is not RightToLeft when BiDiMode:= beRightToLeft
DescriptionTPanel.Caption is not RightToLeft when BiDiMode:= beRightToLeft. Punctuation is misplaced.
Tagsbidi
Fixed in Revision
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0019303 acknowledged Lazarus BiDi meta issue 
related to 0019255 closedJuha Manninen Patches Patch for TPanel to correct TPanel.Caption when BiDiMode:= bdRightToLeft. 

Activities

2011-03-19 12:44

 

TPanel BiDi.JPG (30,609 bytes)   
TPanel BiDi.JPG (30,609 bytes)   

Avishai

2011-03-19 12:46

reporter   ~0046674

I uploaded a file to show this.

Vincent Snijders

2011-03-30 22:59

manager   ~0046984

Can you upload the project sources too?

Avishai

2011-03-31 08:51

reporter   ~0046998

This is all it takes, but you will have to install Hebrew on your system to see it correctly. Set TApplication to bdRightToLeft. Add a TPanel and TLabel to the form. What appears on the TLabel is correct and the TPanel is wrong.
------------

const
  TextStr = 'אבישי (גור)';

procedure TForm1.FormCreate(Sender: TObject);
begin
  Application.BiDiMode:= bdRightToLeft;
  Panel1.Caption:= TextStr;
  Label1.Caption:= TextStr;
end;

Vincent Snijders

2011-03-31 10:36

manager   ~0047002

That is why I asked for the sources zipped in a file, so I don't have to enter the Hebrew text.

2011-03-31 18:41

 

BiDiPanel.zip (311,567 bytes)

Avishai

2011-03-31 18:43

reporter   ~0047022

OK, I uploaded the Source Files. I hope this helps :)

Avishai

2011-04-27 08:37

reporter   ~0047824

I have a partial fix for TPanel.Caption for BiDiMode:= bdRightToLeft, but it only displays the Caption correctly at RunTime. I uploaded a zip file with the modified code. All of my changes are marked as

//==== Avishai's Code
...
//==== End of Avishai's Code

2011-04-28 16:51

 

custompanel.zip (1,958 bytes)

Juha Manninen

2011-05-07 11:22

developer   ~0048107

This got solved together with the related issue but I can't change this issue because its [Packages] Category. (not enough rights)

Avishai

2011-10-03 14:10

reporter   ~0052443

Can we close this issue now?

Issue History

Date Modified Username Field Change
2011-03-19 12:39 Avishai New Issue
2011-03-19 12:39 Avishai Widgetset => Win32/Win64
2011-03-19 12:40 Avishai Tag Attached: bidi
2011-03-19 12:44 Avishai File Added: TPanel BiDi.JPG
2011-03-19 12:46 Avishai Note Added: 0046674
2011-03-30 22:58 Vincent Snijders LazTarget => -
2011-03-30 22:58 Vincent Snijders Status new => acknowledged
2011-03-30 22:59 Vincent Snijders Note Added: 0046984
2011-03-30 22:59 Vincent Snijders Status acknowledged => feedback
2011-03-30 22:59 Vincent Snijders LazTarget - => 1.2
2011-03-31 08:51 Avishai Note Added: 0046998
2011-03-31 10:36 Vincent Snijders Note Added: 0047002
2011-03-31 18:41 Avishai File Added: BiDiPanel.zip
2011-03-31 18:43 Avishai Note Added: 0047022
2011-04-27 08:37 Avishai Note Added: 0047824
2011-04-28 16:51 Avishai File Added: custompanel.zip
2011-05-06 22:13 Juha Manninen Relationship added related to 0019303
2011-05-07 10:52 Juha Manninen Relationship added related to 0019255
2011-05-07 11:22 Juha Manninen Note Added: 0048107
2011-10-03 14:10 Avishai Note Added: 0052443
2011-10-03 14:39 Vincent Snijders Status feedback => resolved
2011-10-03 14:39 Vincent Snijders Resolution open => fixed
2011-10-03 14:39 Vincent Snijders Assigned To => Vincent Snijders
2011-10-03 15:46 Avishai Status resolved => closed