View Issue Details

IDProjectCategoryView StatusLast Update
0019047LazarusIDEpublic2012-03-13 18:51
ReporterbarloneAssigned ToJuha Manninen 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.30.1 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0019047: Access violation after load compiler options
DescriptionProject->Project options->"...", Save to file, Load from file, Ok - access violation.

Bad that no DELETE or CLEAR button in dialog "Open or Load Compiler Options". Is able another method to clear this list?
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Zeljan Rikalo

2011-07-02 17:15

developer   ~0049583

I cannot reproduce under linux (qt and gtk2), so can be some win32 issue.
Can you provide some trace about that av ?

eclipticon

2011-09-14 22:52

reporter   ~0051824

Last edited: 2011-09-14 22:59

I can reproduce the problem on Win32 and I am very interested to get rid of it. Any help I can provide here with tracking down this problem?

Juha Manninen

2011-09-15 02:27

developer   ~0051837

Yes, it happens only with 0.9.30.x, on any platform. In Lazarus trunk it works ok.
If someone finds the commit in trunk that fixed it, or provides a patch, I can try to apply it to fixes branch.
Otherwise I will recommend switching to trunk.
@eclipticon Unless you compile from source, no. Unfortunately Lazarus installers don't include debug information :( (Think I'll add a RFE for Lazarus to make a separate debug file available for release)

@Juha Is a new bugfix release planned/expected?

Juha Manninen

2011-09-15 09:32

developer   ~0051846

Flávio, apparently the bugfix release has been delayed. Vincent has promised to make the release, I just apply fixes to the branch.
Vincent seems to be busy but I hope he can make the release soon.

barlone

2012-03-13 18:51

reporter   ~0057599

Thanks to all

Issue History

Date Modified Username Field Change
2011-03-31 19:45 barlone New Issue
2011-03-31 19:45 barlone Widgetset => Win32/Win64
2011-07-02 17:15 Zeljan Rikalo LazTarget => -
2011-07-02 17:15 Zeljan Rikalo Note Added: 0049583
2011-07-02 17:15 Zeljan Rikalo Status new => feedback
2011-09-14 22:52 eclipticon Note Added: 0051824
2011-09-14 22:59 eclipticon Note Edited: 0051824
2011-09-15 02:21 Juha Manninen Status feedback => assigned
2011-09-15 02:21 Juha Manninen Assigned To => Juha Manninen
2011-09-15 02:27 Juha Manninen Note Added: 0051837
2011-09-15 02:27 Juha Manninen Status assigned => feedback
2011-09-15 04:16 Flávio Etrusco (notifications not working) Note Added: 0051839
2011-09-15 09:32 Juha Manninen Note Added: 0051846
2012-03-13 14:07 Vincent Snijders Status feedback => resolved
2012-03-13 14:07 Vincent Snijders Fixed in Version => 0.9.31 (SVN)
2012-03-13 14:07 Vincent Snijders Resolution open => fixed
2012-03-13 18:51 barlone Status resolved => closed
2012-03-13 18:51 barlone Note Added: 0057599