View Issue Details

IDProjectCategoryView StatusLast Update
0019058LazarusIDEpublic2013-06-09 13:46
ReporterDavid Chen Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product Version0.9.30 
Summary0019058: Path Problem of 0.9.30 (released on 2011-03-22)
DescriptionWhen I open a project file with non-English(I use Chinese) path, it can be edited and saved. But when I compile it, Lazarus cannot finish the compiling.(it shows something like "Cannot open file xxx.lpr") It would be okay if I change the path into full English. This problem is not exist in 0.9.28.2. The version I test was downloaded from sourceforge and released on March 22nd, 2011.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0019483 closedJuha Manninen Lazarus cannot build to a directory which has unicode characters in its name 
related to 0020835 closedBart Broersma ExpandFileNameUTF8 broken 

Activities

Juha Manninen

2011-05-28 14:12

developer   ~0048680

Does it happen also with trunk 0.9.31?

Issue History

Date Modified Username Field Change
2011-04-01 19:59 David Chen New Issue
2011-04-01 19:59 David Chen Widgetset => Win32/Win64
2011-05-28 14:12 Juha Manninen LazTarget => -
2011-05-28 14:12 Juha Manninen Note Added: 0048680
2011-05-28 14:12 Juha Manninen Status new => feedback
2011-06-04 19:55 Juha Manninen Relationship added related to 0019483
2011-12-07 22:45 Juha Manninen Relationship added related to 0020835
2013-06-09 13:45 Bart Broersma Relationship replaced duplicate of 0019483
2013-06-09 13:46 Bart Broersma Status feedback => resolved
2013-06-09 13:46 Bart Broersma Resolution open => duplicate
2013-06-09 13:46 Bart Broersma Assigned To => Bart Broersma