View Issue Details

IDProjectCategoryView StatusLast Update
0019089LazarusDebuggerpublic2011-05-02 12:14
ReporterAlexander S. KleninAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0019089: Memory leak in TGDBTypes.CreateFromCSV
DescriptionCall trace for block $125E41D8 size 352

$00B7A90C TGDBTYPES__CREATEFROMCSV, line 1308 of C:/lazarus/debugger/gdbtypeinfo.pp
$00B793CB DOCLASS, line 936 of C:/lazarus/debugger/gdbtypeinfo.pp
$00B78E4D PROCESSCLASS, line 1076 of C:/lazarus/debugger/gdbtypeinfo.pp
$00B78640 TGDBTYPE__PROCESSEXPRESSION, line 1282 of C:/lazarus/debugger/gdbtypeinfo.pp
$00B5DABC TGDBMIDEBUGGERCOMMAND__GETGDBTYPEINFO, line 8633 of C:/lazarus/debugger/gdbmidebugger.pp
$00B5FFEC TRYEXECUTE, line 10016 of C:/lazarus/debugger/gdbmidebugger.pp
$00B5F727 TGDBMIDEBUGGERCOMMANDEVALUATE__DOEXECUTE, line 10099 of C:/lazarus/debugger/gdbmidebugger.pp
$00B5ED02 TGDBMIDEBUGGERCOMMAND__EXECUTE, line 8866 of C:/lazarus/debugger
TagsNo tags attached.
Fixed in Revision30515
LazTarget0.99.0
Widgetset
Attached Files

Activities

Martin Friebe

2011-05-01 15:14

manager   ~0047947

Please test, and close if ok.

The leak would sometimes have been triggered if (for example) execution was continued, while watches were still evaluating.
However it depends on exact timing.

Alexander S. Klenin

2011-05-02 12:14

developer   ~0047966

Since it is hard to test, closing "optimistically" --
will reopen if the issue will trigger again.

Issue History

Date Modified Username Field Change
2011-04-04 18:35 Alexander S. Klenin New Issue
2011-04-04 18:35 Alexander S. Klenin Status new => assigned
2011-04-04 18:35 Alexander S. Klenin Assigned To => Marc Weustink
2011-04-04 18:35 Alexander S. Klenin LazTarget => -
2011-04-06 12:31 Martin Friebe Assigned To Marc Weustink => Martin Friebe
2011-05-01 15:14 Martin Friebe Fixed in Revision => 30515
2011-05-01 15:14 Martin Friebe LazTarget - => 0.99.0
2011-05-01 15:14 Martin Friebe Status assigned => resolved
2011-05-01 15:14 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2011-05-01 15:14 Martin Friebe Resolution open => fixed
2011-05-01 15:14 Martin Friebe Note Added: 0047947
2011-05-01 15:14 Martin Friebe Target Version => 0.99.0
2011-05-02 12:14 Alexander S. Klenin Status resolved => closed
2011-05-02 12:14 Alexander S. Klenin Note Added: 0047966