View Issue Details

IDProjectCategoryView StatusLast Update
0019091LazarusIDEpublic2011-10-05 15:47
ReporterAlexander S. Klenin Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Summary0019091: Collection editor is not updated after adding item via OI
DescriptionSee summary.
Steps To Reproduce1) Add a component with collection property (I tested on TChart)
2) Open collection editor
3) Add an item via object inspector
=>
Collection editor is not updated.
TagsNo tags attached.
Fixed in Revisionr32702
LazTarget-
Widgetset
Attached Files

Relationships

related to 0019090 closedVincent Snijders List-out-of-bounds in collection editor after deleting item in OI 

Activities

Juha Manninen

2011-04-26 11:22

developer   ~0047784

What collection editor?

Alexander S. Klenin

2011-04-26 12:43

developer   ~0047789

I am not sure what are you asking.
Do you get more than one editor on step 2?
I thought it is a singleton.

Juha Manninen

2011-09-29 09:23

developer   ~0052271

Is this issue still valid?
Collection editor means the "Edit Series" window in TChart, right.
I still don't know how to add items to it using OI. The same "Edit Series" opens from OI.

silvioprog

2011-09-29 12:32

reporter   ~0052274

See:

http://silvioprog.com.br/video/collection/collection.html

Alexander S. Klenin

2011-09-29 13:14

developer   ~0052276

Juha: no, "edit series" calls non-standard series editor implemented in TAChart,
which works ok AFAIK.
This bug is about the standard collection editor.
You can add items from OI by right-clicking and choosing "Add item".

silvio: You video demonstrates the collection editor, but not this bug.
Is this what you intended?

Juha Manninen

2011-09-29 22:03

developer   ~0052286

Last edited: 2011-09-29 22:05

Ok, so you must have used AxisList with TChart then. I didn't find other standard collections there. You could have mentioned it.

There are collections in other components like StringGrid.Columns.
Indeed, the collection editor's list is not updated when using "Add item" on OI.

Juha Manninen

2011-10-05 13:39

developer   ~0052552

Please test.
GlobalDesignHook.PersistentAdded was not called for collection items. I fixed it and added a handler.

Alexander S. Klenin

2011-10-05 15:47

developer   ~0052569

Works, thanks

Issue History

Date Modified Username Field Change
2011-04-04 18:58 Alexander S. Klenin New Issue
2011-04-04 18:58 Alexander S. Klenin LazTarget => -
2011-04-26 11:22 Juha Manninen Note Added: 0047784
2011-04-26 11:22 Juha Manninen Status new => feedback
2011-04-26 12:43 Alexander S. Klenin Note Added: 0047789
2011-04-27 12:37 Alexander S. Klenin Status feedback => new
2011-09-06 19:52 Zeljan Rikalo Relationship added has duplicate 0019829
2011-09-29 09:23 Juha Manninen Note Added: 0052271
2011-09-29 09:23 Juha Manninen Status new => feedback
2011-09-29 12:32 silvioprog Note Added: 0052274
2011-09-29 13:14 Alexander S. Klenin Note Added: 0052276
2011-09-29 22:03 Juha Manninen Note Added: 0052286
2011-09-29 22:03 Juha Manninen Status feedback => confirmed
2011-09-29 22:05 Juha Manninen Note Edited: 0052286
2011-10-03 09:05 Juha Manninen Relationship added related to 0019090
2011-10-03 09:06 Juha Manninen Relationship deleted has duplicate 0019829
2011-10-05 13:39 Juha Manninen Fixed in Revision => r32702
2011-10-05 13:39 Juha Manninen Status confirmed => resolved
2011-10-05 13:39 Juha Manninen Resolution open => fixed
2011-10-05 13:39 Juha Manninen Assigned To => Juha Manninen
2011-10-05 13:39 Juha Manninen Note Added: 0052552
2011-10-05 15:47 Alexander S. Klenin Status resolved => closed
2011-10-05 15:47 Alexander S. Klenin Note Added: 0052569