View Issue Details

IDProjectCategoryView StatusLast Update
0019110LazarusLCLpublic2014-10-31 17:52
ReporterDRIGUS GmbHAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version 
Summary0019110: [WinCE] TToolButton/TSpeedButton has a black background
DescriptionIf you use a TToolButton or a flat TSpeedButton and set the property Down to TRUE, the background is painted black. See attached picture/project.
Additional InformationLazarus 0.9.31 r30164 FPC 2.4.3 i386-win32-win32/win64
Windows CE Embedded 6.0 (with "XP Theme")

See also 0013022.
TagsNo tags attached.
Fixed in Revision46732
LazTarget-
WidgetsetWinCE
Attached Files

Relationships

related to 0013022 closedFelipe Monteiro de Carvalho Lazarus TSpeedButton has black background in WinCE 
related to 0026748 closedFelipe Monteiro de Carvalho Patches [Patch] Improved CreateBrushIndirect workaround 

Activities

2011-04-06 15:23

 

2011_4_6__15_8_52.PNG (5,089 bytes)
2011_4_6__15_8_52.PNG (5,089 bytes)

2011-04-06 15:23

 

Lazarus.zip (129,035 bytes)

DRIGUS GmbH

2011-04-06 15:28

reporter   ~0047276

Regarding 0013022 I can't say if this issue is a regression or not. We start using Lazarus for Windows CE developing in 2009/2010 and noticed this problem very early.

Andrew G. Khodotov

2014-09-19 19:21

reporter   ~0077435

I think patch from http://bugs.freepascal.org/view.php?id=26748 [^] can solve this problem.

Felipe Monteiro de Carvalho

2014-10-31 17:52

developer   ~0078787

The patch was applied, so please reopen if the problem isn't solved.

Issue History

Date Modified Username Field Change
2011-04-06 15:23 DRIGUS GmbH New Issue
2011-04-06 15:23 DRIGUS GmbH File Added: 2011_4_6__15_8_52.PNG
2011-04-06 15:23 DRIGUS GmbH Widgetset => WinCE
2011-04-06 15:23 DRIGUS GmbH File Added: Lazarus.zip
2011-04-06 15:28 DRIGUS GmbH Note Added: 0047276
2011-07-28 14:42 Felipe Monteiro de Carvalho Relationship added related to 0013022
2011-07-28 14:42 Felipe Monteiro de Carvalho Status new => assigned
2011-07-28 14:42 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2014-09-19 19:21 Andrew G. Khodotov Note Added: 0077435
2014-09-20 00:15 Juha Manninen Relationship added related to 0026748
2014-10-31 17:52 Felipe Monteiro de Carvalho Fixed in Revision => 46732
2014-10-31 17:52 Felipe Monteiro de Carvalho LazTarget => -
2014-10-31 17:52 Felipe Monteiro de Carvalho Note Added: 0078787
2014-10-31 17:52 Felipe Monteiro de Carvalho Status assigned => resolved
2014-10-31 17:52 Felipe Monteiro de Carvalho Resolution open => fixed