View Issue Details

IDProjectCategoryView StatusLast Update
0019158Packages-public2013-12-23 23:35
ReporterAvishai Assigned ToMaxim Ganetsky  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version0.9.31 (SVN) 
Summary0019158: TCheckListBox does not mirror properly when BiDiMode:= bdRightToLeft.
DescriptionTCheckListBox does not mirror properly when BiDiMode:= bdRightToLeft. The CheckBox should be on the Right and the text should be Right Aligned like TCheckBox and TCheckGroup.
Tagsbidi
Fixed in Revision
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0025408 closedMaxim Ganetsky Lazarus BiDiMode and FlipChildren issues with TRadioGroup, TCheckGroup and TCheckedListbox 
related to 0019303 acknowledged Lazarus BiDi meta issue 

Activities

2011-04-14 10:16

 

CheckListBoxBiDi.zip (154,170 bytes)

Issue History

Date Modified Username Field Change
2011-04-14 10:16 Avishai New Issue
2011-04-14 10:16 Avishai File Added: CheckListBoxBiDi.zip
2011-04-14 10:16 Avishai Widgetset => Win32/Win64
2011-04-14 10:20 Avishai Tag Attached: bidi
2011-05-06 22:15 Juha Manninen Relationship added related to 0019303
2011-10-05 16:37 Vincent Snijders LazTarget => 1.2
2011-10-05 16:37 Vincent Snijders Status new => acknowledged
2013-12-23 21:15 Maxim Ganetsky Relationship added duplicate of 0025408
2013-12-23 21:15 Maxim Ganetsky Status acknowledged => resolved
2013-12-23 21:15 Maxim Ganetsky Resolution open => fixed
2013-12-23 21:15 Maxim Ganetsky Assigned To => Maxim Ganetsky
2013-12-23 21:16 Maxim Ganetsky Resolution fixed => duplicate
2013-12-23 23:35 Avishai Status resolved => closed