View Issue Details

IDProjectCategoryView StatusLast Update
0019192LazarusLCLpublic2011-12-01 11:26
ReporterEddyAssigned ToMaxim Ganetsky 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.30Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0019192: TButtonPanel: disabling buttons in object inspector does not work
DescriptionTButtonPanel contains 4 buttons and each button has an Enabled property. When the Enabled properties are set to false in the object inspector, the buttons are still enabled when running the program.
Setting the properties to false programmaticaly works (this can be used as a workaround).
TagsNo tags attached.
Fixed in Revision30424
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Maxim Ganetsky

2011-04-18 23:09

developer   ~0047579

Cannot reproduce neither in 0.9.30 nor in 0.9.31 version in Windows XP SP2.

2011-04-21 22:50

 

invalidbuttonpanel.png (25,287 bytes)
invalidbuttonpanel.png (25,287 bytes)

Eddy

2011-04-21 22:52

reporter   ~0047673

Last edited: 2011-04-21 22:53

See attachment.
The problem lies in the 'Close' button. If that is removed from the panel (ShowButtons property) the problem is clearly visible.
In the Object Inspector the Enabled property of OKButton is set to False. And still the button is enabled in the running program.

Maxim Ganetsky

2011-04-22 01:14

developer   ~0047678

Ah, now I see.

Please test and close if ok.

Eddy

2011-04-22 01:20

reporter   ~0047679

:-)
Will do with the next available daily snapshot (current is 30406).

2011-04-22 11:06

 

nontransparantclose.png (9,677 bytes)
nontransparantclose.png (9,677 bytes)

Eddy

2011-04-22 11:08

reporter   ~0047690

Tested with Lazarus-0.9.31-30424-fpc-2.4.2-20110422-win32.
Disabling buttons now works. But the Close button glyph isn't transparent anymore (see attached image).

Was this an easy fix? (I'd like to apply it to the 0.9.30 stable version as well.)

Maxim Ganetsky

2011-04-23 00:56

developer   ~0047698

Close button glyph wasn't transparent before too, this is another problem. It is also not transparent in 0.9.30.1, as far as I can see.

The fix is queued for merge to fixes branch.

2011-04-23 14:09

 

closeok.png (5,149 bytes)
closeok.png (5,149 bytes)

Eddy

2011-04-23 14:09

reporter   ~0047708

It's ok for 0.9.30 (see image). Else I wouldn't have noticed it.

Issue History

Date Modified Username Field Change
2011-04-18 14:34 Eddy New Issue
2011-04-18 14:34 Eddy Widgetset => Win32/Win64
2011-04-18 23:09 Maxim Ganetsky LazTarget => -
2011-04-18 23:09 Maxim Ganetsky Status new => resolved
2011-04-18 23:09 Maxim Ganetsky Resolution open => unable to reproduce
2011-04-18 23:09 Maxim Ganetsky Assigned To => Maxim Ganetsky
2011-04-18 23:09 Maxim Ganetsky Note Added: 0047579
2011-04-21 22:50 Eddy File Added: invalidbuttonpanel.png
2011-04-21 22:52 Eddy Status resolved => assigned
2011-04-21 22:52 Eddy Resolution unable to reproduce => reopened
2011-04-21 22:52 Eddy Note Added: 0047673
2011-04-21 22:53 Eddy Note Edited: 0047673
2011-04-21 22:53 Eddy Note Edited: 0047673
2011-04-22 00:50 Maxim Ganetsky Assigned To Maxim Ganetsky =>
2011-04-22 00:50 Maxim Ganetsky Status assigned => confirmed
2011-04-22 01:14 Maxim Ganetsky Fixed in Revision => 30424
2011-04-22 01:14 Maxim Ganetsky Status confirmed => resolved
2011-04-22 01:14 Maxim Ganetsky Fixed in Version => 0.9.31 (SVN)
2011-04-22 01:14 Maxim Ganetsky Resolution reopened => fixed
2011-04-22 01:14 Maxim Ganetsky Assigned To => Maxim Ganetsky
2011-04-22 01:14 Maxim Ganetsky Note Added: 0047678
2011-04-22 01:20 Eddy Note Added: 0047679
2011-04-22 11:06 Eddy File Added: nontransparantclose.png
2011-04-22 11:08 Eddy Note Added: 0047690
2011-04-23 00:56 Maxim Ganetsky Note Added: 0047698
2011-04-23 14:09 Eddy File Added: closeok.png
2011-04-23 14:09 Eddy Note Added: 0047708
2011-12-01 11:26 Marc Weustink Status resolved => closed