View Issue Details

IDProjectCategoryView StatusLast Update
0019210LazarusIDEpublic2011-07-04 14:12
ReporterVladimir ZhirovAssigned ToMaxim Ganetsky 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0019210: Ok and Cancel buttons in dialogs are too close to each other
DescriptionIn most IDE dialogs, e.g.:
* File - New
* Source - Unit Information
* Project - New Project
* Project - Project Options
* Tools - Options
the distance between OK and Cancel buttons is much smaller than between other right-aligned buttons (see the attached screenshot for an example).

This distance should be equal for all right-aligned buttons.
Additional InformationTested with Lazarus SVN rev. 30406 on Linux (using Qt and GTK2 widgetsets) and Win32. I believe this issue is widgetset independent and may be caused by TButtonPanel.
TagsNo tags attached.
Fixed in Revision31383
LazTarget-
Widgetset
Attached Files

Activities

2011-04-21 22:55

 

buttons.png (4,709 bytes)
buttons.png (4,709 bytes)

2011-04-21 23:18

 

button_panel.png (3,578 bytes)
button_panel.png (3,578 bytes)

Vojtech Cihak

2011-04-21 23:19

reporter   ~0047674

Last edited: 2011-04-21 23:33

So I add my one...
I have no space between (mainly Cancel & OK) buttons at all. I use Linux, KDE4 (scheme Plastique) Qt4.7
I see no property of TButtonPanel to affect it. (Spacing does not work)

It happens everywhere: TabOrder, New Project..., see screenshot

Lazarus 0.9.31 r30265M FPC 2.5.1 x86_64-linux-qt

Maxim Ganetsky

2011-06-25 15:09

developer   ~0049394

Please test and close if ok.

Vladimir Zhirov

2011-07-04 14:12

reporter   ~0049648

It is fixed now. Thanks, Maxim.

Issue History

Date Modified Username Field Change
2011-04-21 22:55 Vladimir Zhirov New Issue
2011-04-21 22:55 Vladimir Zhirov File Added: buttons.png
2011-04-21 23:18 Vojtech Cihak File Added: button_panel.png
2011-04-21 23:19 Vojtech Cihak Note Added: 0047674
2011-04-21 23:33 Vojtech Cihak Note Edited: 0047674
2011-06-25 15:09 Maxim Ganetsky Fixed in Revision => 31383
2011-06-25 15:09 Maxim Ganetsky LazTarget => -
2011-06-25 15:09 Maxim Ganetsky Status new => resolved
2011-06-25 15:09 Maxim Ganetsky Fixed in Version => 0.9.31 (SVN)
2011-06-25 15:09 Maxim Ganetsky Resolution open => fixed
2011-06-25 15:09 Maxim Ganetsky Assigned To => Maxim Ganetsky
2011-06-25 15:09 Maxim Ganetsky Note Added: 0049394
2011-07-04 14:12 Vladimir Zhirov Status resolved => closed
2011-07-04 14:12 Vladimir Zhirov Note Added: 0049648