View Issue Details

IDProjectCategoryView StatusLast Update
0019232LazarusIDEpublic2011-04-26 22:13
ReportersfeinstAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0019232: CTRL-Left not working in IDE editor
DescriptionI am running the latest SVN. In the editor I've tried gtk2 and Windows), when I press ctrl-left (expecting the cursor to move one "word" left), it will move the cursor one word, but the next press won't work. The behavior is not consistent in how much the cursor moves. Sometimes it moves a full word (and if it does, then the next ctrl-left will work as well) and sometimes a partial word (which occurs most of the time and will not allow another ctrl-left until on another line). It seems to be related to tab position.

The issue does not occur for ctrl-right.
TagsNo tags attached.
Fixed in Revision30480
LazTarget0.99.0
Widgetset
Attached Files

Activities

Juha Manninen

2011-04-26 08:52

developer   ~0047777

Can't reproduce here.
Make sure you don't have old compiled units when building trunk.

Martin Friebe

2011-04-26 15:10

manager   ~0047792

please test and close if ok

sfeinst

2011-04-26 16:36

reporter   ~0047796

I always use make clean bigide.
I tried make clean then make bigide, but had the same problem.
I tried manually removing all .o and .ppu files because I found some older ones make clean missed, but I still have the problem. When I get to my Linux machine (I can't do this on my Windows machine right now), I'll try wiping out the entire Lazarus directory and pulling down latest code again to see if that helps.

Martin Friebe

2011-04-26 17:22

manager   ~0047797

I was able to reproduce before, but not after the changes I made.

It may depend on your settings.
Please attach your editoroptions.xml from C:\Users\<USERNAME>\AppData\Local\lazarus or ~/.lazarus folder

Please also attach a textfile with a text or unit, in which the issue can be reproduced. (you can attach as private file, if publication is an issue).
Specify the steps to reproduce => e.g initial caret position.

---
I don't think you need to delete your whole directory => if unsure if uit was compiled, just put a temporary syntax error into it (changes are in the main synedit.pp file). To ensure your file is updated search for a procedure called "PrevWordLogicalPos" in synedit.pp => it was introduced with the change.

Martin Friebe

2011-04-26 17:23

manager   ~0047798

please also note, that my previous "please test..." was not based on Juha's note, but meant to test with rev 30480, in which a change was made.

sfeinst

2011-04-26 20:35

reporter   ~0047809

Sorry, I did misunderstand what you wrote and did not look closely to see the rev had changed. I updated again and it is fixed. Thank you for the work.

Martin Friebe

2011-04-26 21:37

manager   ~0047816

No problem

sfeinst

2011-04-26 22:13

reporter   ~0047817

Working fine with latest build rev.

Issue History

Date Modified Username Field Change
2011-04-26 03:16 sfeinst New Issue
2011-04-26 03:16 sfeinst Widgetset => GTK 2, Win32/Win64, QT
2011-04-26 08:52 Juha Manninen Note Added: 0047777
2011-04-26 10:28 Martin Friebe Status new => assigned
2011-04-26 10:28 Martin Friebe Assigned To => Martin Friebe
2011-04-26 15:10 Martin Friebe Fixed in Revision => 30480
2011-04-26 15:10 Martin Friebe LazTarget => 0.99.0
2011-04-26 15:10 Martin Friebe Widgetset GTK 2, Win32/Win64, QT =>
2011-04-26 15:10 Martin Friebe Status assigned => resolved
2011-04-26 15:10 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2011-04-26 15:10 Martin Friebe Resolution open => fixed
2011-04-26 15:10 Martin Friebe Note Added: 0047792
2011-04-26 15:10 Martin Friebe Target Version => 0.99.0
2011-04-26 16:36 sfeinst Status resolved => assigned
2011-04-26 16:36 sfeinst Resolution fixed => reopened
2011-04-26 16:36 sfeinst Note Added: 0047796
2011-04-26 17:22 Martin Friebe Note Added: 0047797
2011-04-26 17:22 Martin Friebe Status assigned => feedback
2011-04-26 17:23 Martin Friebe Note Added: 0047798
2011-04-26 20:35 sfeinst Note Added: 0047809
2011-04-26 21:37 Martin Friebe Status feedback => resolved
2011-04-26 21:37 Martin Friebe Resolution reopened => fixed
2011-04-26 21:37 Martin Friebe Note Added: 0047816
2011-04-26 22:13 sfeinst Status resolved => closed
2011-04-26 22:13 sfeinst Note Added: 0047817