View Issue Details

IDProjectCategoryView StatusLast Update
0019257LazarusLCLpublic2011-05-05 22:57
Reporterrusty_robotAssigned ToJesus Reyes 
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0019257: StringGrid: Row and Col properties don't affect scroll bars when set just after bulk insert
DescriptionStringGrid is filled in a loop. After that, Row and/or Col properties are set. But grid's scroll bars don't reflect it until manual navigation.
Additional InformationSee screenshots and sample project.
TagsNo tags attached.
Fixed in Revision30548
LazTarget0.99.0
WidgetsetGTK 2
Attached Files

Relationships

related to 0019266 resolvedVincent Snijders Scrolling dont work in Ubuntu 11.04 
related to 0019369 acknowledged Scrollbars do not respond correctly when resizing TDrawGrid 

Activities

2011-04-28 23:16

 

after_fill.png (31,705 bytes)
after_fill.png (31,705 bytes)

2011-04-28 23:16

 

after_manual_scroll.png (30,978 bytes)
after_manual_scroll.png (30,978 bytes)

2011-04-28 23:17

 

fill_grid.zip (3,319 bytes)

rusty_robot

2011-05-02 22:03

reporter   ~0047990

Have reproduced this issue on Lazarus 0.9.30 (Win32) and 0.9.31 (Linux Qt). It seems the problem is widgetset-independent.

Juha Manninen

2011-05-03 11:01

developer   ~0047999

I improved the behavior in r30537 but still could not solve it.
Now the scrollbars are updated when you click the grid to give it focus.
How to fix properly such redraw issues?

Jesus Reyes

2011-05-03 18:07

developer   ~0048005

This fix doesn't look right as it forces redraws and produces false notifications where it shouldn't. I will take a look

Jesus Reyes

2011-05-04 21:02

developer   ~0048026

please test.

Juha Manninen

2011-05-04 23:45

developer   ~0048032

Last edited: 2011-05-04 23:46

Cool! It works.

rusty_robot

2011-05-05 22:57

reporter   ~0048064

Thanks!

Issue History

Date Modified Username Field Change
2011-04-28 23:16 rusty_robot New Issue
2011-04-28 23:16 rusty_robot File Added: after_fill.png
2011-04-28 23:16 rusty_robot Widgetset => GTK 2
2011-04-28 23:16 rusty_robot File Added: after_manual_scroll.png
2011-04-28 23:17 rusty_robot File Added: fill_grid.zip
2011-05-02 22:03 rusty_robot Note Added: 0047990
2011-05-03 11:01 Juha Manninen Note Added: 0047999
2011-05-03 11:54 Juha Manninen Relationship added related to 0019266
2011-05-03 18:05 Jesus Reyes Status new => assigned
2011-05-03 18:05 Jesus Reyes Assigned To => Jesus Reyes
2011-05-03 18:07 Jesus Reyes Note Added: 0048005
2011-05-04 21:02 Jesus Reyes Fixed in Revision => 30548
2011-05-04 21:02 Jesus Reyes LazTarget => 0.99.0
2011-05-04 21:02 Jesus Reyes Status assigned => resolved
2011-05-04 21:02 Jesus Reyes Fixed in Version => 0.9.31 (SVN)
2011-05-04 21:02 Jesus Reyes Resolution open => fixed
2011-05-04 21:02 Jesus Reyes Note Added: 0048026
2011-05-04 21:02 Jesus Reyes Target Version => 0.99.0
2011-05-04 23:45 Juha Manninen Note Added: 0048032
2011-05-04 23:46 Juha Manninen Note Edited: 0048032
2011-05-05 22:57 rusty_robot Status resolved => closed
2011-05-05 22:57 rusty_robot Note Added: 0048064
2011-05-18 16:35 Juha Manninen Relationship added related to 0019369