View Issue Details

IDProjectCategoryView StatusLast Update
0019342LazarusIDEpublic2011-12-12 12:58
ReporterMarelisAssigned ToVincent Snijders 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSUbuntuOS Version11.04
Product Version0.9.31 (SVN)Product Build30688 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0019342: Cwin32wsdialogs.pp(704,55) Error: Incompatible types (cross: linux to win64)
DescriptionTBuildManager.SetBuildTargetIDE OS=Win64 CPU=x86_64 WS=win32
TPkgManager.SaveAutoInstallDependencies A Printer4Lazarus
TPkgManager.SaveAutoInstallDependencies A SDFLaz
TPkgManager.SaveAutoInstallDependencies A RunTimeTypeInfoControls
TPkgManager.SaveAutoInstallDependencies A printers4lazide
TPkgManager.SaveAutoInstallDependencies A MemDSLaz
TPkgManager.SaveAutoInstallDependencies A TurboPowerIPro
TPkgManager.SaveAutoInstallDependencies A jcfidelazarus
TPkgManager.SaveAutoInstallDependencies A ChmHelpPkg
TPkgManager.SaveAutoInstallDependencies A fpcunitide
TPkgManager.SaveAutoInstallDependencies A ProjTemplates
TPkgManager.SaveAutoInstallDependencies A TAChartLazarusPkg
TPkgManager.SaveAutoInstallDependencies A ToDoListLaz
TPkgManager.SaveAutoInstallDependencies A DBFLaz
TPkgManager.SaveAutoInstallDependencies A SQLDBLaz
TLazPackageGraph.CheckIfCurPkgOutDirNeedsCompile Compile was incomplete for LCL 1.0.1
[TExternalToolList.Run] CmdLine="/usr/bin/fpc -MObjFPC -Scghi -O1 -Twin64 -Px86_64 -gl -vewnhi -l -Fi/usr/local/share/lazarus/lcl/interfaces/win32 -Fu/usr/local/share/lazarus/lcl/interfaces/win32 -Fu/usr/local/share/lazarus/lcl/units/x86_64-win64 -Fu/usr/local/share/lazarus/packager/units/x86_64-win64 -Fu/usr/local/share/lazarus/lcl/interfaces/ -FU/usr/local/share/lazarus/lcl/units/x86_64-win64/win32/ -vm5044 -gw -gl -godwarfsets -gh -gt -Co -Cr -Ci -Sa lcl.pas" WorkDir="/usr/local/share/lazarus/lcl/interfaces/"
Hint: Start of reading config file /etc/fpc.cfg
Hint: End of reading config file /etc/fpc.cfg
Free Pascal Compiler version 2.4.2 [2011/05/11] for x86_64
Copyright (c) 1993-2010 by Florian Klaempfl
Target OS: Win64 for x64
Compiling lcl.pas
Compiling ./win32/alllclintfunits.pas
Compiling ./win32/win32wsdialogs.pp
Compiling ./win32/win32int.pp
win32int.pp(27,26) Warning: User defined: Fix implicit pointer conversions
Compiling ./win32/win32wsfactory.pas
Compiling ./win32/win32wsdialogs.pp
win32wsdialogs.pp(704,55) Error: Incompatible types: got "<procedure variable type of function(QWord,LongWord,Int64,Int64):QWord;StdCall>" expected "<procedure variable type of function(QWord,LongWord,Int64,Int64):DWord;StdCall>"
win32wsdialogs.pp(1501) Fatal: There were 1 errors compiling module, stopping
TExternalToolList.Run Exception: /usr/local/share/lazarus/lcl/interfaces/win32/win32wsdialogs.pp(1501) Fatal: There were 1 errors compiling module, stopping
TMainIDE.DoBuildLazarus: Compile AutoInstall Packages failed.
TagsNo tags attached.
Fixed in Revision30897
LazTarget-
Widgetset
Attached Files

Relationships

related to 0019163 closedPaul Ishenin Since revision 30288 64-bit version of Lazarus wont compile. 

Activities

Marelis

2011-05-19 14:53

reporter   ~0048412

7 days and 7 nights ... no reaction, no assignment, no interest ... well ...

Issue History

Date Modified Username Field Change
2011-05-12 08:32 Marelis New Issue
2011-05-19 14:53 Marelis Note Added: 0048412
2011-10-05 16:42 Vincent Snijders Relationship added related to 0019163
2011-10-05 16:42 Vincent Snijders Fixed in Revision => 30897
2011-10-05 16:42 Vincent Snijders LazTarget => -
2011-10-05 16:42 Vincent Snijders Status new => resolved
2011-10-05 16:42 Vincent Snijders Fixed in Version => 0.9.31 (SVN)
2011-10-05 16:42 Vincent Snijders Resolution open => fixed
2011-10-05 16:42 Vincent Snijders Assigned To => Vincent Snijders
2011-12-12 12:58 Marelis Status resolved => closed