View Issue Details

IDProjectCategoryView StatusLast Update
0019359LazarusPackagespublic2011-11-11 22:56
Reporterfrancesco sammarcoAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform386OSWindowsOS VersionXP
Product VersionProduct Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0019359: Lazreport (Export PDF) problem
DescriptionHello, I encountered the following bug when I create a report with lazreport and then print to PDF using ReportName.ExportTo (TFrTNPDFExportFilter, PDFName) happens to the images that I enter in the report are printed with the proportions of the object and not the picture proportions of the original picture. Does anyone know why?
TagsNo tags attached.
Fixed in Revision30828
LazTarget-
Widgetset
Attached Files

Activities

francesco sammarco

2011-05-18 13:32

reporter   ~0048374

If there are doubts about this issue do not hesitate to contact me.

Jesus Reyes

2011-05-20 16:23

developer   ~0048443

please test

francesco sammarco

2011-05-25 13:24

reporter   ~0048569

It's ok

francesco sammarco

2011-05-25 13:25

reporter   ~0048570

Thank you

francesco sammarco

2011-05-25 13:25

reporter   ~0048571

When will this change on a daily snapshot?

Jesus Reyes

2011-05-25 19:38

developer   ~0048585

I corrected the "fixed in revision" number, for win32 + fpc 2.4.2 currently there is a snapshot with revision 30864 which should include this change.

If you agree please close this report.

francesco sammarco

2011-05-26 07:47

reporter   ~0048602

ok

Jesus Reyes

2011-06-25 21:30

developer   ~0049412

please close this report

Jesus Reyes

2011-10-30 04:19

developer   ~0053617

Fixed the revision number again this time is set to the right revision this problem was fixed.

Jesus Reyes

2011-11-01 21:26

developer   ~0053727

resolved again

francesco sammarco

2011-11-03 16:32

reporter   ~0053777

Solved

francesco sammarco

2011-11-11 14:15

reporter   ~0054015

Last edited: 2011-11-11 14:39

I installed this version of lazarus and when I create a PDF of the same problem persists. You can not fix once and for all?

http://sourceforge.net/projects/lazarus/files/Lazarus%20Windows%2032%20bits/Lazarus%200.9.30.2/


Tell me the link where to get just the correct package.
lazreportpdfexport.lpk

So at least the next time my exhaust from them even if you correct it everywhere as has been so far!

Jesus Reyes

2011-11-11 19:29

developer   ~0054019

The problem is fixed in revision 30828, I initially confused that number and write down another which I later have corrected, but the fix has not changed, when I write "fixed again" I meant the report itself, not the code.

But what is the problem? is the bug back? if this is the case, provide a minimum compilable project that show the problem.

Can you at least write what revision are you using? How can I help you when you don't provide the minimum information?.

this:

"So at least the next time my exhaust from them even if you correct it everywhere as has been so far!"

Is so confusing, that I prefer you to write in your native language so I can translate it myself. Or write it in spanish if you prefer.



Jesus Reyes

2011-11-11 22:56

developer   ~0054023

Resolved again.

I think I know what have happened, you are trying 0.9.30.2 which do not include this fix, in order to test this fix you need any 0.9.31 version posterior to revision 30828, enter http://www.lazarus.freepascal.org/index.php look for "Daily Snapshots" link at the left panel, and you will find installers for 0.9.31.

Next time when your report a bug, click the lazarus help menu then click "about lazarus" submenu, then right click the lazarus image, select "copy version information to clipboard" and you can paste that to your report.

Issue History

Date Modified Username Field Change
2011-05-16 07:56 francesco sammarco New Issue
2011-05-16 11:52 Jonas Maebe Project FPC => Lazarus
2011-05-17 22:55 Jesus Reyes Status new => assigned
2011-05-17 22:55 Jesus Reyes Assigned To => Jesus Reyes
2011-05-18 13:32 francesco sammarco Note Added: 0048374
2011-05-20 16:23 Jesus Reyes Fixed in Revision => 19359
2011-05-20 16:23 Jesus Reyes LazTarget => -
2011-05-20 16:23 Jesus Reyes Status assigned => resolved
2011-05-20 16:23 Jesus Reyes Fixed in Version => 0.9.31 (SVN)
2011-05-20 16:23 Jesus Reyes Resolution open => fixed
2011-05-20 16:23 Jesus Reyes Note Added: 0048443
2011-05-25 13:24 francesco sammarco Status resolved => assigned
2011-05-25 13:24 francesco sammarco Resolution fixed => reopened
2011-05-25 13:24 francesco sammarco Note Added: 0048569
2011-05-25 13:25 francesco sammarco Note Added: 0048570
2011-05-25 13:25 francesco sammarco Note Added: 0048571
2011-05-25 19:38 Jesus Reyes Fixed in Revision 19359 => 30839
2011-05-25 19:38 Jesus Reyes Note Added: 0048585
2011-05-26 07:47 francesco sammarco Note Added: 0048602
2011-06-25 21:30 Jesus Reyes Note Added: 0049412
2011-10-30 04:19 Jesus Reyes Fixed in Revision 30839 => 30828
2011-10-30 04:19 Jesus Reyes Note Added: 0053617
2011-11-01 21:26 Jesus Reyes Status assigned => resolved
2011-11-01 21:26 Jesus Reyes Resolution reopened => fixed
2011-11-01 21:26 Jesus Reyes Note Added: 0053727
2011-11-03 16:32 francesco sammarco Status resolved => closed
2011-11-03 16:32 francesco sammarco Note Added: 0053777
2011-11-11 14:15 francesco sammarco Status closed => assigned
2011-11-11 14:15 francesco sammarco Resolution fixed => reopened
2011-11-11 14:15 francesco sammarco Note Added: 0054015
2011-11-11 14:16 francesco sammarco Note Edited: 0054015
2011-11-11 14:39 francesco sammarco Note Edited: 0054015
2011-11-11 19:29 Jesus Reyes Note Added: 0054019
2011-11-11 19:29 Jesus Reyes Status assigned => feedback
2011-11-11 22:56 Jesus Reyes Status feedback => resolved
2011-11-11 22:56 Jesus Reyes Resolution reopened => fixed
2011-11-11 22:56 Jesus Reyes Note Added: 0054023