View Issue Details

IDProjectCategoryView StatusLast Update
0019483LazarusIDEpublic2015-11-11 19:19
ReporterJuha Manninen Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN) 
Summary0019483: Lazarus cannot build to a directory which has unicode characters in its name
DescriptionBased on earlier Unicode experiments and some related bug reports I created a windows directory with cyrillic chars:
 C:\SW\Лейбл1
I can open it and copy/paste its name here so I guess it is a valid directory name.
Then I tried to save a test project there and got an error:
  Unable to create file "C:\SW\?????1\project1.ico".

Tested on WinXP running under VirtualBox.

On Linux there is no such problem.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0028991 resolvedMattias Gaertner Lazarus IDE cannot compile projects with FPC if path has national symbols 
related to 0012627 closedBart Broersma Lazarus Can't open project if its path include Unicode (non ANSI) chars 
related to 0011207 resolvedMattias Gaertner Lazarus Invalid handling of non-english characters in filenames 
related to 0014467 assignedMarco van de Voort FPC DirectoryExists returns false for directory names containing non-ASCII characters (win32) 
related to 0015233 feedbackMarco van de Voort FPC SysUtils.GetTempFileName returns garbage when system temp path contains non-ASCII characters 
related to 0028962 new FPC Compilation failed if Unicode char is in project name or path 
has duplicate 0019058 resolvedBart Broersma Lazarus Path Problem of 0.9.30 (released on 2011-03-22) 
has duplicate 0022309 closedJuha Manninen Lazarus Win32: memory leak, after save project fails 
related to 0020672 closedFelipe Monteiro de Carvalho Lazarus IDE not start if Windows user name non ascii 
related to 0020835 closedBart Broersma Lazarus ExpandFileNameUTF8 broken 
related to 0021817 resolvedJuha Manninen Lazarus "FileUtil.CopyFile" would failed to work with Unicode Characters filename. 
related to 0022216 resolvedMattias Gaertner Lazarus Lazarus cannot write configuration when directory contains accents 
related to 0026812 resolvedMattias Gaertner Lazarus Packages located in a folder named in Cyrillc letters cannot be installed. 
related to 0026623 closedMattias Gaertner Lazarus Problems with non ascii characters in project path 

Activities

Juha Manninen

2011-06-04 22:08

developer   ~0048839

FPC may have its own problems with unicode paths but Lazarus can solve this kind of problems by UTF8 functions defined in LCL.

Juha Manninen

2013-06-06 10:40

developer   ~0068086

This has improved. Now Lazarus trunk can save to the directory, but FPC still gives an error:

Failed to execute C:\FPC\2.6.2\bin\i386-win32\fpc.exe -B -MObjFPC -Scghi -O1 -g -gl -WG -vewnhi -FiC:\SW\?????1\lib\i386-win32 -FuC:\SW\lazarus\lcl\units\i386-win32\win32 -FuC:\SW\lazarus\lcl\units\i386-win32 -FuC:\SW\lazarus\components\lazutils\lib\i386-win32 -FuC:\SW\lazarus\packager\units\i386-win32 -FuC:\SW\?????1\ -FUC:\SW\?????1\lib\i386-win32\ -l -dLCL -dLCLwin32 project1.lpr : 267

Bart Broersma

2013-06-06 23:48

developer   ~0068102

Ultimately this may be an fpc issue.
Tthe compiler treats all commandline parameters as ANSI (current codepage).
The only solution would be to pass the parameters as widestrings, and let the compiler use the widestring version of GetCommandLine API.

Péter Gábor

2013-06-09 15:31

reporter   ~0068157

Other related bug reports: 0014467, 0015233

Bart Broersma

2013-06-19 12:18

developer   ~0068392

Updated the summary to reflect the problem.
Opening/saving has been resolved.

Bart Broersma

2015-11-11 18:01

developer   ~0087240

I don't have a clue how to solve this. Unassigning.

Juha Manninen

2015-11-11 19:19

developer   ~0087243

There is an FPC issue and another Lazarus issue open. Resolving this one ...

Issue History

Date Modified Username Field Change
2011-06-04 19:51 Juha Manninen New Issue
2011-06-04 19:51 Juha Manninen LazTarget => -
2011-06-04 19:51 Juha Manninen Widgetset => Win32/Win64
2011-06-04 19:55 Juha Manninen Relationship added related to 0019058
2011-06-04 19:55 Juha Manninen Relationship added related to 0019467
2011-06-04 19:56 Juha Manninen Description Updated
2011-06-04 21:56 Juha Manninen Relationship added related to 0012627
2011-06-04 22:03 Juha Manninen Relationship added related to 0011207
2011-06-04 22:08 Juha Manninen Note Added: 0048839
2011-10-05 17:07 Vincent Snijders Status new => acknowledged
2011-11-13 00:54 Juha Manninen Relationship added related to 0020672
2011-12-07 22:42 Juha Manninen Relationship added related to 0020835
2012-04-24 20:20 Juha Manninen Relationship added related to 0021817
2012-06-14 20:21 Juha Manninen Relationship added related to 0022216
2012-06-24 23:06 Juha Manninen Relationship added has duplicate 0022309
2013-06-06 10:40 Juha Manninen Note Added: 0068086
2013-06-06 23:48 Bart Broersma Note Added: 0068102
2013-06-09 13:45 Bart Broersma Relationship replaced has duplicate 0019058
2013-06-09 15:31 Péter Gábor Note Added: 0068157
2013-06-09 16:02 Juha Manninen Relationship added related to 0014467
2013-06-09 16:02 Juha Manninen Relationship added related to 0015233
2013-06-19 12:18 Bart Broersma Note Added: 0068392
2013-06-19 12:18 Bart Broersma Summary Lazarus can't save to a directory which has unicode characters in its name => Lazarus build to a directory which has unicode characters in its name
2013-06-19 12:19 Bart Broersma Summary Lazarus build to a directory which has unicode characters in its name => Lazarus cannot build to a directory which has unicode characters in its name
2013-06-30 09:21 Juha Manninen Relationship deleted related to 0019467
2014-10-03 01:27 Juha Manninen Relationship added related to 0026812
2014-10-29 08:21 Juha Manninen Relationship added related to 0026623
2015-11-11 14:51 Juha Manninen Relationship added has duplicate 0028991
2015-11-11 14:51 Juha Manninen Assigned To => Bart Broersma
2015-11-11 14:51 Juha Manninen Status acknowledged => assigned
2015-11-11 18:01 Bart Broersma Note Added: 0087240
2015-11-11 18:01 Bart Broersma Assigned To Bart Broersma =>
2015-11-11 18:01 Bart Broersma Status assigned => acknowledged
2015-11-11 19:10 Juha Manninen Relationship added related to 0028962
2015-11-11 19:17 Juha Manninen Relationship replaced duplicate of 0028991
2015-11-11 19:19 Juha Manninen Note Added: 0087243
2015-11-11 19:19 Juha Manninen Status acknowledged => resolved
2015-11-11 19:19 Juha Manninen Resolution open => fixed
2015-11-11 19:19 Juha Manninen Assigned To => Juha Manninen
2015-11-11 19:19 Juha Manninen Status resolved => closed