View Issue Details

IDProjectCategoryView StatusLast Update
0019594LazarusLCLpublic2011-09-15 01:50
ReportersilvioprogAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0019594: Bug in THintWindow: not accept click in Windows
DescriptionHi.

The code in attached work only in Linux (Ubuntu). In Windows not
receives click in the hint window.

This this code work in older revisions of the Lazarus 0.9.31 and FPC 2.5.1. :(

Thx.
TagsNo tags attached.
Fixed in Revision31468
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

2011-06-20 12:52

 

THintWindows_BUG.zip (2,561 bytes)

Zeljan Rikalo

2011-06-20 15:56

developer   ~0049235

So this is regression.

silvioprog

2011-06-21 12:52

reporter   ~0049255

Is there a way to solve it based on previous versions? :/

Thx.

Zeljan Rikalo

2011-06-21 13:04

developer   ~0049256

Don't know ... somebody must look into first ...

Juha Manninen

2011-06-21 19:45

developer   ~0049267

Last edited: 2011-06-21 19:46

Yes, it works in fixes 0.9.30 branch but not in trunk, on Windows.
I would do "git bisect" but I didn't get git working properly on Windows.
If someone can find the revision that broke it, good.

August Klein

2011-06-21 22:04

reporter   ~0049269

Problem is revision 30059. It must be reversed.

http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=rev&root=lazarus&revision=30059

silvioprog

2011-06-22 17:56

reporter   ~0049305

I'll wait anxiously...

silvioprog

2011-06-24 16:38

reporter   ~0049364

The problem continues.

Lazarus 0.9.31 r31358 FPC 2.5.1 i386-win32-win32/win64

Paul Ishenin

2011-06-30 08:32

manager   ~0049526

THintWindow should not accept clicks by design - it is a transparent for all of events window which only shows information.

But if you create a custom hint window you should have a way to override the default behavior. Therefore I moved WM_NCHITTEST to the LCL from the win32 widgetset. So if you really need you can override LM_NCHITTEST message in your custom hint window class.

Please test and close if ok.

silvioprog

2011-06-30 15:04

reporter   ~0049534

The problem persists on Windows (7). On Linux (Ubuntu 11.04) is OK.

Lazarus 0.9.31 r31477 FPC 2.5.1 i386-win32-win32/win64

silvioprog

2011-09-15 01:50

reporter   ~0051836

Now is solved to me. Thx guys.

Lazarus 0.9.31 r32336 FPC 2.5.1 i386-win32-win32/win64

Issue History

Date Modified Username Field Change
2011-06-20 12:52 silvioprog New Issue
2011-06-20 12:52 silvioprog File Added: THintWindows_BUG.zip
2011-06-20 12:52 silvioprog Widgetset => Win32/Win64
2011-06-20 15:56 Zeljan Rikalo Note Added: 0049235
2011-06-21 12:52 silvioprog Note Added: 0049255
2011-06-21 13:04 Zeljan Rikalo Note Added: 0049256
2011-06-21 19:45 Juha Manninen LazTarget => -
2011-06-21 19:45 Juha Manninen Note Added: 0049267
2011-06-21 19:45 Juha Manninen Status new => confirmed
2011-06-21 19:45 Juha Manninen Target Version => 0.99.0
2011-06-21 19:46 Juha Manninen Note Edited: 0049267
2011-06-21 22:04 August Klein Note Added: 0049269
2011-06-22 17:56 silvioprog Note Added: 0049305
2011-06-23 21:21 Juha Manninen Status confirmed => assigned
2011-06-23 21:21 Juha Manninen Assigned To => Juha Manninen
2011-06-24 09:54 Juha Manninen Assigned To Juha Manninen => Paul Ishenin
2011-06-24 16:38 silvioprog Note Added: 0049364
2011-06-30 08:32 Paul Ishenin Fixed in Revision => 31468
2011-06-30 08:32 Paul Ishenin Status assigned => resolved
2011-06-30 08:32 Paul Ishenin Fixed in Version => 0.9.31 (SVN)
2011-06-30 08:32 Paul Ishenin Resolution open => fixed
2011-06-30 08:32 Paul Ishenin Note Added: 0049526
2011-06-30 15:04 silvioprog Note Added: 0049534
2011-09-15 01:50 silvioprog Status resolved => closed
2011-09-15 01:50 silvioprog Note Added: 0051836