View Issue Details

IDProjectCategoryView StatusLast Update
0019597LazarusIDEpublic2011-10-06 11:37
ReporterHoward Page-ClarkAssigned ToVincent Snijders 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.30.1 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0019597: IDE memory leak in package chmhelp shown by heaptrace
DescriptionBuilding Lazarus LCL and IDE with the heaptrace unit shows an 8 byte leak arising at line 30 of chmlcl.pas, following the creation of baseURL: THelpBaseURLObject.
See attached .png of heaptrace output.
Additional InformationThis has been an issue for quite some time.
TagsNo tags attached.
Fixed in Revision31314
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

2011-06-20 20:57

 

heaptrace.png (91,191 bytes)
heaptrace.png (91,191 bytes)

Anton

2011-06-20 21:52

reporter   ~0049242

I hope it fixed in rev 31314

Vincent Snijders

2011-10-06 11:37

manager   ~0052623

I cannot reproduce it anymore, so probably fixed.

Issue History

Date Modified Username Field Change
2011-06-20 20:57 Howard Page-Clark New Issue
2011-06-20 20:57 Howard Page-Clark File Added: heaptrace.png
2011-06-20 20:57 Howard Page-Clark Widgetset => Win32/Win64
2011-06-20 21:11 Mattias Gaertner LazTarget => -
2011-06-20 21:11 Mattias Gaertner Summary IDE memory leak shown by heaptrace => IDE memory leak in package chmhelp shown by heaptrace
2011-06-20 21:52 Anton Note Added: 0049242
2011-10-06 11:37 Vincent Snijders Fixed in Revision => 31314
2011-10-06 11:37 Vincent Snijders Status new => resolved
2011-10-06 11:37 Vincent Snijders Fixed in Version => 0.9.31 (SVN)
2011-10-06 11:37 Vincent Snijders Resolution open => fixed
2011-10-06 11:37 Vincent Snijders Assigned To => Vincent Snijders
2011-10-06 11:37 Vincent Snijders Note Added: 0052623