View Issue Details

IDProjectCategoryView StatusLast Update
0019640LazarusWidgetsetpublic2018-07-22 09:17
ReporterZeljan RikaloAssigned ToZeljan Rikalo 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0019640: Qt: QStandardItemH - reminder for Den
DescriptionQStandardItem_setData() & QStandardItem_data() have param role: QtItemDataRole, but it should be role: Integer.
It works fine, just tested all cases.
Why is this so ? I'm creating new class for TCustomListView.ViewStyle=vsReport , which does not use QTreeWidget ,but QTreeView with QStandardItemModel.
It's already finished, and this change is needed in qt45.pas only.
TagsNo tags attached.
Fixed in Revision
LazTargetpost 1.10
WidgetsetQT
Attached Files

Activities

Zeljan Rikalo

2011-06-28 19:56

developer   ~0049483

QItemSelection is needed because we need QItemSelectionModel_selectionChanged() event also.

Zeljan Rikalo

2014-09-12 08:44

developer   ~0077119

postponed, not important for 1.4

Zeljan Rikalo

2018-07-22 09:17

developer   ~0109618

No need for this reminder anymore.

Issue History

Date Modified Username Field Change
2011-06-27 15:43 Zeljan Rikalo New Issue
2011-06-27 15:43 Zeljan Rikalo LazTarget => -
2011-06-27 15:43 Zeljan Rikalo Widgetset => QT
2011-06-27 17:52 Zeljan Rikalo Status new => assigned
2011-06-27 17:52 Zeljan Rikalo Assigned To => Zeljan Rikalo
2011-06-28 19:56 Zeljan Rikalo Note Added: 0049483
2011-11-07 20:58 Zeljan Rikalo LazTarget - => 1.0
2012-01-08 10:07 Zeljan Rikalo LazTarget 1.0 => 1.2
2014-01-14 15:16 Martin Friebe LazTarget 1.2 => 1.4
2014-09-12 08:44 Zeljan Rikalo LazTarget 1.4 => post 1.4
2014-09-12 08:44 Zeljan Rikalo Note Added: 0077119
2018-07-22 09:17 Zeljan Rikalo LazTarget post 1.4 => post 1.10
2018-07-22 09:17 Zeljan Rikalo Note Added: 0109618
2018-07-22 09:17 Zeljan Rikalo Status assigned => resolved
2018-07-22 09:17 Zeljan Rikalo Resolution open => fixed
2018-07-22 09:17 Zeljan Rikalo Status resolved => closed