View Issue Details

IDProjectCategoryView StatusLast Update
0019654LazarusLCLpublic2011-09-12 23:23
ReporterAvishai Assigned ToJesus Reyes  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version0.9.31 (SVN) 
Summary0019654: TCheckGroup produces Error when BiDiMode:= bdRightToLeft
DescriptionTCheckGroup produces the following Error when BiDiMode:= bdRightToLeft

Project project1 raised exception class 'EReadError' with message:
Error reading CheckGroup1.BiDiMode: Unknown property: "BiDiMode"

I looked at TCheckGroup code and it has BiDiMode and ParentBiDiMode in published properties. They also show up in property editor.
Tagsbidi
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0019303 acknowledged BiDi meta issue 

Activities

Avishai

2011-06-29 07:59

reporter   ~0049494

I noticed that if TCheckGroup Parent is bdRightToLeft and TCheckGroup.ParentBiDiMode:= True, this Error does not occur.

Jesus Reyes

2011-09-12 21:39

developer   ~0051756

I was not able to reproduce this problem in a standalone project after in r32301.

Previous to this revision, at what revision were BiDiMode and ParentBiDiMode properties published?

Please check again and close this issue it's ok.

Issue History

Date Modified Username Field Change
2011-06-29 07:52 Avishai New Issue
2011-06-29 07:52 Avishai Widgetset => Win32/Win64
2011-06-29 07:56 Avishai Tag Attached: bidi
2011-06-29 07:59 Avishai Note Added: 0049494
2011-06-29 09:12 Juha Manninen Relationship added related to 0019303
2011-09-12 21:34 Jesus Reyes Status new => assigned
2011-09-12 21:34 Jesus Reyes Assigned To => Jesus Reyes
2011-09-12 21:38 Jesus Reyes LazTarget => -
2011-09-12 21:39 Jesus Reyes Status assigned => resolved
2011-09-12 21:39 Jesus Reyes Resolution open => unable to reproduce
2011-09-12 21:39 Jesus Reyes Note Added: 0051756
2011-09-12 23:23 Avishai Status resolved => closed