View Issue Details

IDProjectCategoryView StatusLast Update
0019688LazarusLCLpublic2012-04-06 16:53
Reportermek Assigned ToZeljan Rikalo  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN) 
Target Version1.2.0 
Summary0019688: (TToolbar)TToolButton behavior not compatible with Delphi
Description

1. press down left mouse button on a TToolButton
2. move mouse pointer out of the TToolButton
3. release left mouse button

Delphi dose not fires a OnClick event, but LCL dose



TagsNo tags attached.
Fixed in Revision36263,36572
LazTarget1.2
WidgetsetGTK, GTK 2, Win32/Win64, WinCE, Carbon, Cocoa, QT
Attached Files

Relationships

related to 0021560 resolvedZeljan Rikalo [Carbon?] TToolButton doesn't work anymore after r36263 

Activities

Andrey Zubarev

2011-07-11 06:24

reporter   ~0049880

Yes, after the button is pressed, it will not cancel. This is not incompatible with delphi, this is the wrong GUI

Zeljan Rikalo

2012-03-23 10:23

developer   ~0057949

This problem exists on all widgetsets...

Zeljan Rikalo

2012-03-23 10:39

developer   ~0057950

Please test and close if ok.
NOTE: csCaptureMouse is enabled for tbsDropDown because it must be so, otherwise we won't have click at all (same in Delphi according to google).

Zeljan Rikalo

2012-04-05 09:03

developer   ~0058319

Reverted csCaptureMouse, added check for mousepos in mouseUp.

Andrey Zubarev

2012-04-05 09:35

reporter   ~0058321

Work properly. Thanks

mek

2012-04-06 16:53

reporter   ~0058371

thanks!

tested on:

Lazarus 1.1 r36568M FPC 2.6.1 i386-win32-win32

Lazarus 1.1 r36617M FPC 2.7.1 x86_64-linux-gtk 2

Issue History

Date Modified Username Field Change
2011-07-06 09:10 mek New Issue
2011-07-06 09:10 mek Widgetset => Win32/Win64
2011-07-11 06:24 Andrey Zubarev Note Added: 0049880
2011-10-06 10:38 Vincent Snijders LazTarget => 1.2
2011-10-06 10:38 Vincent Snijders Status new => acknowledged
2011-10-06 10:38 Vincent Snijders Target Version => 1.2.0
2012-03-23 10:23 Zeljan Rikalo Note Added: 0057949
2012-03-23 10:39 Zeljan Rikalo Fixed in Revision => 36263
2012-03-23 10:39 Zeljan Rikalo Widgetset Win32/Win64 => GTK, GTK 2, Win32/Win64, WinCE, Carbon, Cocoa, QT
2012-03-23 10:39 Zeljan Rikalo Status acknowledged => resolved
2012-03-23 10:39 Zeljan Rikalo Resolution open => fixed
2012-03-23 10:39 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-03-23 10:39 Zeljan Rikalo Note Added: 0057950
2012-03-26 08:18 Zeljan Rikalo Relationship added related to 0021560
2012-04-05 09:03 Zeljan Rikalo Status resolved => assigned
2012-04-05 09:03 Zeljan Rikalo Resolution fixed => reopened
2012-04-05 09:03 Zeljan Rikalo Fixed in Revision 36263 => 36263,36572
2012-04-05 09:03 Zeljan Rikalo Status assigned => resolved
2012-04-05 09:03 Zeljan Rikalo Resolution reopened => fixed
2012-04-05 09:03 Zeljan Rikalo Note Added: 0058319
2012-04-05 09:35 Andrey Zubarev Note Added: 0058321
2012-04-06 16:53 mek Status resolved => closed
2012-04-06 16:53 mek Note Added: 0058371