View Issue Details

IDProjectCategoryView StatusLast Update
0019702LazarusIDEpublic2011-10-30 21:03
ReporterBenito van der ZanderAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformamd64OSDebianOS Versionsqueeze
Product VersionProduct Buildr31625 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0019702: can't enlarge edit on a form
DescriptionI can't enlarge an TEdit on the form anymore with the resize edge buttons, although shrinking it works.
TagsNo tags attached.
Fixed in Revision32231
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

has duplicate 0020189 resolvedZeljan Rikalo Lazarus Trunk can't enlarge a TButton in the Form Designer 
related to 0019761 closedZeljan Rikalo scrollbar doesn't capture mouse 

Activities

Benito van der Zander

2011-07-10 00:10

reporter   ~0049848

although setting the width property works fine

Juha Manninen

2011-07-10 14:37

developer   ~0049861

Yes, enlarging is difficult although somehow possible.
If you resize one step backwards and then forward, it usually succeeds.

The functonality has gone worse. I tested an old version in which the enlargement usually succeeded at first time but not after that.

Robson Dantas

2011-07-10 16:54

reporter   ~0049867

Correct, using the mouse does not work. Already using SHIFT + arrow works.

Benito van der Zander

2011-07-10 17:08

reporter   ~0049868

It seems to fail as soon as the mouse pointer leaves the edit area. (=> even moving the controls doesn't work if you move the mouse to fast)

Zeljan Rikalo

2011-09-10 08:29

developer   ~0051681

@Benito, please test with >= r32231 and give feedback, I think it's fixed.

Benito van der Zander

2011-09-20 01:10

reporter   ~0052048

Almost fixed.

It works horizontally, but not vertically.

Since the height is fixed, resizing it vertically, should cause it to move. However, it only moves up, not down, unless the mouse cursor it carefully placed inside the edit.

Zeljan Rikalo

2011-09-24 10:05

developer   ~0052135

@Benito, what if you set AutoSize = False of TEdit ?

Benito van der Zander

2011-09-25 20:14

reporter   ~0052187

then it is resized

Zeljan Rikalo

2011-10-30 21:03

developer   ~0053654

This isn't ws bug anymore. Behaviour which you mentioned in your last note (it moves up) is same under qt too (so I guess all ws are affected), and this is designer bug (if it's bug).
This one is fixed, please close.

Issue History

Date Modified Username Field Change
2011-07-10 00:08 Benito van der Zander New Issue
2011-07-10 00:08 Benito van der Zander Widgetset => GTK 2
2011-07-10 00:10 Benito van der Zander Note Added: 0049848
2011-07-10 14:37 Juha Manninen LazTarget => -
2011-07-10 14:37 Juha Manninen Note Added: 0049861
2011-07-10 14:37 Juha Manninen Status new => confirmed
2011-07-10 16:54 Robson Dantas Note Added: 0049867
2011-07-10 17:08 Benito van der Zander Note Added: 0049868
2011-07-23 10:23 Juha Manninen Relationship added related to 0019761
2011-09-10 00:36 Juha Manninen Relationship added has duplicate 0020189
2011-09-10 08:29 Zeljan Rikalo Note Added: 0051681
2011-09-10 08:29 Zeljan Rikalo Status confirmed => feedback
2011-09-19 11:54 Vincent Snijders Fixed in Revision => 32231
2011-09-19 11:54 Vincent Snijders Status feedback => resolved
2011-09-19 11:54 Vincent Snijders Fixed in Version => 0.9.31 (SVN)
2011-09-19 11:54 Vincent Snijders Resolution open => fixed
2011-09-19 11:54 Vincent Snijders Assigned To => Vincent Snijders
2011-09-20 01:10 Benito van der Zander Status resolved => assigned
2011-09-20 01:10 Benito van der Zander Resolution fixed => reopened
2011-09-20 01:10 Benito van der Zander Note Added: 0052048
2011-09-20 07:56 Vincent Snijders Assigned To Vincent Snijders =>
2011-09-20 07:56 Vincent Snijders Status assigned => acknowledged
2011-09-24 10:05 Zeljan Rikalo Note Added: 0052135
2011-09-25 20:14 Benito van der Zander Note Added: 0052187
2011-10-30 21:03 Zeljan Rikalo Status acknowledged => resolved
2011-10-30 21:03 Zeljan Rikalo Resolution reopened => fixed
2011-10-30 21:03 Zeljan Rikalo Assigned To => Zeljan Rikalo
2011-10-30 21:03 Zeljan Rikalo Note Added: 0053654