View Issue Details

IDProjectCategoryView StatusLast Update
0019839LazarusIDEpublic2011-09-03 22:06
ReporterFlávio Etrusco (notifications not working)Assigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0019839: SIGSEGV/AV in CodeTools
DescriptionThe exception doesn't appear to the user and I don't know how to reproduce, I'm just reporting it in case there's a false assumption easily detectable ;-)

As can be seen from the stacktrace TCodeHelpManager.CodeNodeToElementName receives a nil value for 'CodeTool', as if CodeToolBoss.CurCodeTool.FindDeclaration returned True but didn't fill CTNode.

{{{
#0 TCODEHELPMANAGER__CODENODETOELEMENTNAME(0x0, 0x0, <error reading variable>, 0x0) at codehelp.pas:1846
0000001 TCODEHELPMANAGER__GETHTMLHINT(0x9c4ccc8, 17, 36, [CHHODECLARATIONHEADER], 0xdff9d8 'lazdoc://', 0xa999f00 '<div class="header">
'0000013#10' <a href="source://C:\Users\etrusco\projetos\lazarus\lcl\stdctrls.pp(1,1)">C:\<wbr/>Users\<wbr/>etrusco\<wbr/>projetos\<wbr/>lazarus\<wbr/>lcl\<wbr/>stdctrls.pp(1,1)</a>'0000013#10..., true, <error reading variable>) at codehelp.pas:2296
0000002 TIDEHELPMANAGER__GETHINTFORSOURCEPOSITION(0xbd0c880 'C:\Users\etrusco\projetos\lazarus\designer\taborderdlg.pas', {X = 17, Y = 36}, 0xdff9d8 'lazdoc://', 0xa999f00 '<div class="header">
'0000013#10' <a href="source://C:\Users\etrusco\projetos\lazarus\lcl\stdctrls.pp(1,1)">C:\<wbr/>Users\<wbr/>etrusco\<wbr/>projetos\<wbr/>lazarus\<wbr/>lcl\<wbr/>stdctrls.pp(1,1)</a>'0000013#10..., [], <error reading variable>) at idehelpmanager.pas:1525
0000003 TMAINIDE__ONSRCNOTEBOOKSHOWHINTFORSOURCE(0xbd548b8, {X = 194, Y = 192}, {X = 17, Y = 36}, <error reading variable>) at main.pp:16194
0000004 TSOURCENOTEBOOK__SHOWSYNEDITHINT({X = 497, Y = 353}, <error reading variable>) at sourceeditor.pp:7409
0000005 TSOURCENOTEBOOK__HINTTIMER(0xbc0e2c0, <error reading variable>) at sourceeditor.pp:7339
0000006 TCUSTOMTIMER__DOONTIMER(<error reading variable>) at customtimer.pas:181
0000007 TCUSTOMTIMER__TIMER(<error reading variable>) at customtimer.pas:156
0000008 TIMERCALLBACKPROC(0, 275, 23420, 125772795) at .\win32\win32callback.inc:2660
0000009 USER32!IsWindowVisible at :0
0000010 ?? at :0
}}}
TagsNo tags attached.
Fixed in Revision32166
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0020103 closedMattias Gaertner Crash when displaying hint of unit in uses clause 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2011-07-30 21:10 Flávio Etrusco (notifications not working) New Issue
2011-07-30 21:10 Flávio Etrusco (notifications not working) LazTarget => -
2011-07-30 21:10 Flávio Etrusco (notifications not working) Widgetset => Win32/Win64
2011-08-14 19:18 Mattias Gaertner Status new => assigned
2011-08-14 19:18 Mattias Gaertner Assigned To => Mattias Gaertner
2011-08-31 00:49 Flávio Etrusco (notifications not working) Relationship added duplicate of 0020103
2011-09-03 22:06 Flávio Etrusco (notifications not working) Fixed in Revision => 32166
2011-09-03 22:06 Flávio Etrusco (notifications not working) Status assigned => resolved
2011-09-03 22:06 Flávio Etrusco (notifications not working) Fixed in Version => 0.9.31 (SVN)
2011-09-03 22:06 Flávio Etrusco (notifications not working) Resolution open => fixed