View Issue Details

IDProjectCategoryView StatusLast Update
0019886LazarusWidgetsetpublic2012-03-12 16:00
Reportercobines Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWin32OSWindows XP 
Product Version0.9.31 (SVN) 
Summary0019886: Form with only width constraint changes height to zero after minimize/restore
DescriptionIf a form has Constraint.MinWidth set but MinHeight is 0 (so, no constraint) then after minimize/restore width is set to MinWidth and height is set to 0.

This stems from the fact that in LCLWin32 minimized form has Width,Height=0. Without constraints the size is somehow remembered upon restore but with MinWidth>0 on minimize the size is set to Width=MinWidth, Height=0. And upon restore those values are used to resize the form thus only the caption bar is visible.

This obviously works in other ways too (MinHeight > 0, MinWidth = 0).

I checked with Linux LCLGTK2, LCLQT and it works fine.
Steps To Reproduce1. Run attached application.
2. Minimize Test Form.
3. Restore Test Form.
TagsNo tags attached.
Fixed in Revisionr33145
LazTarget0.99.0
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0020670 closedPaul Ishenin Cannot restore/show hidden minimized form [regression] 

Activities

2011-08-04 00:10

 

cobines

2011-08-04 13:50

reporter   ~0050431

In branch fixes_0_9_30 rev. 31839 the bug does not exist.

With trunk the bug appears since revision r29756:
http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=rev&root=lazarus&revision=29756

Juha Manninen

2011-11-15 12:04

developer   ~0054096

Last edited: 2011-11-16 10:16

I can't reproduce this with the latest Lazarus trunk [edit: on Windows 7].
Maybe it is a Windows version dependent issue.

cobines

2011-11-16 03:13

reporter   ~0054107

Indeed, it doesn't happen anymore after rev. 33145, however 33145 in turn causes a regression: 0020670.

Juha Manninen

2011-11-16 10:25

developer   ~0054117

I resolved this and set 20670 as a related issue.

Issue History

Date Modified Username Field Change
2011-08-04 00:10 cobines New Issue
2011-08-04 00:10 cobines File Added: form_constraints_test.zip
2011-08-04 00:10 cobines Widgetset => Win32/Win64
2011-08-04 13:50 cobines Note Added: 0050431
2011-08-05 01:33 Maxim Ganetsky LazTarget => 0.99.0
2011-08-05 01:33 Maxim Ganetsky Status new => acknowledged
2011-08-05 01:33 Maxim Ganetsky Target Version => 0.99.0
2011-08-05 01:37 Maxim Ganetsky Status acknowledged => confirmed
2011-11-15 12:04 Juha Manninen Note Added: 0054096
2011-11-16 03:13 cobines Note Added: 0054107
2011-11-16 10:16 Juha Manninen Note Edited: 0054096
2011-11-16 10:23 Juha Manninen Relationship added related to 0020670
2011-11-16 10:24 Juha Manninen Fixed in Revision => r33145
2011-11-16 10:24 Juha Manninen Status confirmed => resolved
2011-11-16 10:24 Juha Manninen Resolution open => fixed
2011-11-16 10:24 Juha Manninen Assigned To => Juha Manninen
2011-11-16 10:25 Juha Manninen Note Added: 0054117
2012-03-12 16:00 cobines Status resolved => closed