View Issue Details

IDProjectCategoryView StatusLast Update
0019920LazarusDebuggerpublic2011-09-08 00:11
ReporterFlávio Etrusco Assigned ToMartin Friebe  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in Version0.9.31 (SVN) 
Summary0019920: Debugger can't evaluate typecast of function parameter
Description1) Place a breakpoint on a TNotifyEvent handler.
2) When the breakpoint is reached try to Evaluate e.g. "tcontrol(sender)".
3) It says "Cannot access memory at address 0x0".
TagsNo tags attached.
Fixed in Revision32217
LazTarget1.0
Widgetset
Attached Files

Activities

Martin Friebe

2011-08-08 11:27

manager   ~0050606

This appears to be for stabs (-g) symbol info only.

As a workaround, please use dwarf (-gw)

Flávio Etrusco

2011-08-26 22:10

developer   ~0051165

As pointed out by Martin in email, this can be worked around by using e.g. "^tcontrol(sender)".

Martin Friebe

2011-09-08 00:10

manager   ~0051576

Please test and close if ok.

Please note, this is intended to fix simple typecasts only. Nested expresions are not covered.

Typecasting a variable will fail, if the value of the variable is nil.

Accessing a member of a typecasted object should work: TFoo(SomeObj).FMember
(actually the last one, was never broken)

btw: seems also gdb 7.0 and up only

Issue History

Date Modified Username Field Change
2011-08-07 00:16 Flávio Etrusco New Issue
2011-08-07 00:16 Flávio Etrusco Status new => assigned
2011-08-07 00:16 Flávio Etrusco Assigned To => Marc Weustink
2011-08-07 00:16 Flávio Etrusco LazTarget => -
2011-08-08 10:58 Martin Friebe Assigned To Marc Weustink => Martin Friebe
2011-08-08 11:27 Martin Friebe Note Added: 0050606
2011-08-26 22:10 Flávio Etrusco Note Added: 0051165
2011-09-08 00:10 Martin Friebe Fixed in Revision => 32217
2011-09-08 00:10 Martin Friebe LazTarget - => 1.0
2011-09-08 00:10 Martin Friebe Status assigned => resolved
2011-09-08 00:10 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2011-09-08 00:10 Martin Friebe Resolution open => fixed
2011-09-08 00:10 Martin Friebe Note Added: 0051576
2011-09-08 00:11 Martin Friebe Target Version => 0.99.0