View Issue Details

IDProjectCategoryView StatusLast Update
0002002LazarusIDEpublic2011-12-01 11:22
ReporterKazimierz KrólAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformAMD AthlonOSWindowsOS VersionXP SP2
Product Version0.9.14Product Build 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0002002: Minimizing forms to buttons during in design mode
Description If I minimize a form so that it will be a button in the bottom left corner of the screen, and then close Lazarus and open it again, the from will not be minimized, but it will be of original size and positioned at bottom left corner (so that only its title bar will be visible). I can provide a screenshot if necessary.
 It doesn't bother me now, but it could be a problem in an application wich uses many forms.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Activities

Boguslaw Brandys

2006-12-07 12:51

developer   ~0010230

Looks like IDE does store window position but not store window state (minimized,maximized)

Paul Ishenin

2009-09-15 09:55

manager   ~0030726

It works at moment. Probably fixed in the mean time. Please note I tell only about IDE forms, not designer forms.

Please close if ok.

Issue History

Date Modified Username Field Change
2006-04-18 05:35 Kazimierz Król New Issue
2006-04-18 05:35 Kazimierz Król Widgetset => Win32
2006-04-18 10:26 Vincent Snijders Target => 1.0
2006-04-18 10:26 Vincent Snijders Status new => acknowledged
2006-12-07 12:51 Boguslaw Brandys Note Added: 0010230
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2009-09-15 09:55 Paul Ishenin Status acknowledged => resolved
2009-09-15 09:55 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2009-09-15 09:55 Paul Ishenin Resolution open => fixed
2009-09-15 09:55 Paul Ishenin Assigned To => Paul Ishenin
2009-09-15 09:55 Paul Ishenin Note Added: 0030726
2011-12-01 11:22 Marc Weustink Status resolved => closed