View Issue Details

IDProjectCategoryView StatusLast Update
0020029FPCCompilerpublic2011-10-17 11:29
ReporterTommi Prami Assigned ToFelipe Monteiro de Carvalho  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in Version3.0.0 
Summary0020029: Linking error in Free Pascal for WinCE "unknown pseudo-op .secrel32"
DescriptionIf I would like to have the Debug version of the IDE, then even the Simpelest WinCE app will crash (Or compiling will crash) on error :


C:\lazarus\packager\units\arm-wince\lazaruspackageintf.s: Assembler messages:
C:\lazarus\packager\units\arm-wince\lazaruspackageintf.s:405: Error: unknown pseudo-op: `.secrel32'
C:\lazarus\packager\units\arm-wince\lazaruspackageintf.s:413: Error: unknown pseudo-op: `.secrel32'
C:\lazarus\packager\registration\lazaruspackageintf.pas(110) Error: Error while assembling exitcode 1
C:\lazarus\packager\registration\lazaruspackageintf.pas(110) Fatal: There were 2 errors compiling module, stopping
Additional InformationFPC 2.4.4
Lazarus 0.9.31

This have been in this way at least from 21.06.2011 (dd.mm.yyyy), when I first encountered this problem, but did not make Bug report because using the Optimized IDE will work. Now I really would like to do some LCL debugging (and I think I have to build at least packages with the Debug information), so I think this is some what important to fix.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId0
FPCTarget
Attached Files

Relationships

related to 0020362 resolvedVincent Snijders Packages dwarf debug information causes problems in WinCE 
related to 0019972 resolvedFelipe Monteiro de Carvalho Packages Crash while closing a modal window on WinCE 

Activities

Felipe Monteiro de Carvalho

2011-09-27 08:59

developer   ~0052214

You don't need a "Debug IDE" to debug the LCL ... your apps already have LCL debug information since you can generate backtraces and the LCL always includes debug info by default AFAIK. I don't see how your apps could have even more debug info...

Ludo Brands

2011-10-07 15:27

developer   ~0052738

This is related to the problem described in http://bugs.freepascal.org/bug_view_advanced_page.php?bug_id=20362. Upgrade to recent lazarus version that doesn't default to dwarf debugging info. .secrel32 pseudo code is only used for dwarf debugging info.

Felipe Monteiro de Carvalho

2011-10-17 07:10

developer   ~0053068

Last edited: 2011-10-17 07:10

This bug has nothing to do with Lazarus. It is a assembler error.

Is the internal assembler default for WinCE? If yes, then it needs to be updated to support or ignore this .secrel32

Ludo Brands

2011-10-17 08:15

developer   ~0053076

The latest wince lazarus +fpc 2.5.1 snapshot on http://www.hu.freepascal.org/lazarus/ contains a newer version of the binutils assembler that supports .secrel32. This assembler works also with fpc 2.4.4 when using the external linker. A bug in the internal fpc linker was solved a few days ago in trunk.

Felipe Monteiro de Carvalho

2011-10-17 10:07

developer   ~0053081

So, if you say that the linker problem was fixed and that the new assembler will be included in future releases, then it seams that the bug is fixed.

Issue History

Date Modified Username Field Change
2011-08-22 08:33 Tommi Prami New Issue
2011-08-22 08:33 Tommi Prami Widgetset => WinCE
2011-09-27 08:59 Felipe Monteiro de Carvalho Note Added: 0052214
2011-09-27 09:02 Felipe Monteiro de Carvalho Relationship added related to 0019972
2011-10-07 15:27 Ludo Brands Note Added: 0052738
2011-10-07 15:44 Vincent Snijders Relationship added related to 0020362
2011-10-07 15:45 Vincent Snijders LazTarget => 0.99.0
2011-10-07 15:45 Vincent Snijders Status new => acknowledged
2011-10-07 15:45 Vincent Snijders Target Version => 0.99
2011-10-17 07:08 Felipe Monteiro de Carvalho Project Packages => FPC
2011-10-17 07:10 Felipe Monteiro de Carvalho FPCOldBugId => 0
2011-10-17 07:10 Felipe Monteiro de Carvalho Note Added: 0053068
2011-10-17 07:10 Felipe Monteiro de Carvalho Product Version 0.9.30.1 (SVN) =>
2011-10-17 07:10 Felipe Monteiro de Carvalho Summary WinCE apps wont compile with IDE build with "Debug IDE" => Linking error in Free Pascal for WinCE "unknown pseudo-op .secrel32"
2011-10-17 07:10 Felipe Monteiro de Carvalho Note Edited: 0053068
2011-10-17 08:15 Ludo Brands Note Added: 0053076
2011-10-17 10:07 Felipe Monteiro de Carvalho Status acknowledged => resolved
2011-10-17 10:07 Felipe Monteiro de Carvalho Fixed in Version => 2.7.1
2011-10-17 10:07 Felipe Monteiro de Carvalho Resolution open => fixed
2011-10-17 10:07 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2011-10-17 10:07 Felipe Monteiro de Carvalho Note Added: 0053081
2011-10-17 10:07 Felipe Monteiro de Carvalho Target Version 0.99 =>
2011-10-17 11:29 Jonas Maebe Category - => Compiler