View Issue Details

IDProjectCategoryView StatusLast Update
0020086LazarusLCLpublic2012-10-06 05:44
ReporterJohn Repucci Assigned ToPaul Ishenin  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version0.9.31 (SVN) 
Target Version1.2.0Fixed in Version0.9.31 (SVN) 
Summary0020086: "Hints" on non-active window are shown
DescriptionWhen a secondary window is active and when the mouse is hovered over a hinted object on the main window, the balloon hint for that object is displayed. In addition, if the tStatusBar is enabled on the secondary window, the hint from the main window shows up in the hint bar of the secondary window.

My preference: hints for objects on non-active windows should be suppressed.

I can tolerate the balloon hints for non-active windows appearing, but when the hints from another form start showing up on the active form, I think that is a bug.

0.9.31-31848-2.5.1, win32-Vista
Additional InformationSteps to reproduce:
New project, add a button
Second window, add a button to it.

Both windows: ShowHint := True
Form1 button: hint := 'Form1.Button1 Hint'
Form2 button: hint := 'Form2.Button1 Hint'

Form1.Button.OnClick := Form2.Show. (need to add Form2 to Form1's uses clause.

run:
hover over Form1-Button - verify balloon hint shows up
Click on Form1-Button - Form2 opens.
hover over Form2-Button - verify balloon hint shows up
with Form2 still the active window, hover the mouse over the Form1 Button, it's hint appears.
--- And I think it should not appear
TagsNo tags attached.
Fixed in Revision
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0020101 closedPaul Ishenin MainMenu and toolbar hints 
related to 0020185 closedPaul Ishenin W32: IDE Hint trigger it's own hiding (Regression?) =>: Debug hints do not show for some values 

Activities

John Repucci

2011-08-28 20:26

reporter   ~0051219

Correction: ... need to add ==Unit2== to Form1's uses clause.

Vincent Snijders

2011-10-06 20:07

manager   ~0052676

Can you upload the example source?

2011-10-10 02:23

 

HintsPub.zip (3,178 bytes)

John Repucci

2011-10-10 02:24

reporter   ~0052813

Done. This was created / tested with:
0.9.31-32432-2.5.1, vin32-Vista.

Juha Manninen

2011-11-12 10:53

developer   ~0054031

Last edited: 2011-11-12 12:42

It is interesting that Delphi 7 has this same feature / bug.
StatusBar with AutoHint shows the hint from another window which doesn't have focus.
I think this is a bug anyway and should be fixed.
It is not a trivial task because the hints are passed around as Application actions and often it is desirable to show them.

Zeljan Rikalo

2012-02-04 14:07

developer   ~0056430

Not blocker, postponed.

Paul Ishenin

2012-03-23 10:24

manager   ~0057943

Please check whether it works better after r36253

Paul Ishenin

2012-03-24 11:47

manager   ~0057978

This is not a bug but designed behavior.

When the second for is enabled it should show hints. Think about the Lazarus IDE - it has many windows: toolbar with components, source editor, object inspector. When I hover mouse over a component icon I want to see the hint with description, same for object inspector. I should not perform extra actions like window activation to get this working.

John Repucci

2012-03-24 17:34

reporter   ~0057986

Reviewing my initial report, I see that I could have improved my report significantly.
I do not have an issue with balloon hints, just the text to statusbar hints.

I have the expectation that hints associated with a form should appear on the statusbar of that form and not appear on the statusbar of another form.

In the attached example, with form2 active, when I hover my mouse over the button on form1, the hint shows up in Form2's Statusbar. I would expect it to show up on Form1's Statusbar.

(note: I just tested with 0.9.31-36282-2.6.1, vin32-Vista; no change in behavior.)

Issue History

Date Modified Username Field Change
2011-08-28 20:21 John Repucci New Issue
2011-08-28 20:21 John Repucci Widgetset => Win32/Win64
2011-08-28 20:26 John Repucci Note Added: 0051219
2011-10-06 20:07 Vincent Snijders LazTarget => -
2011-10-06 20:07 Vincent Snijders Note Added: 0052676
2011-10-06 20:07 Vincent Snijders Status new => feedback
2011-10-07 10:18 Juha Manninen Relationship added related to 0020101
2011-10-07 10:24 Juha Manninen Relationship added related to 0020185
2011-10-10 02:23 John Repucci File Added: HintsPub.zip
2011-10-10 02:24 John Repucci Note Added: 0052813
2011-10-10 07:50 Vincent Snijders LazTarget - => 1.0
2011-10-10 07:50 Vincent Snijders Status feedback => acknowledged
2011-10-10 07:50 Vincent Snijders Target Version => 1.0.0
2011-11-12 10:53 Juha Manninen Note Added: 0054031
2011-11-12 12:00 Juha Manninen Note Edited: 0054031
2011-11-12 12:42 Juha Manninen Note Edited: 0054031
2012-02-04 14:07 Zeljan Rikalo LazTarget 1.0 => 1.2
2012-02-04 14:07 Zeljan Rikalo Note Added: 0056430
2012-03-13 07:50 Vincent Snijders Target Version 1.0.0 => 1.2.0
2012-03-23 10:24 Paul Ishenin Note Added: 0057943
2012-03-23 10:24 Paul Ishenin Status acknowledged => feedback
2012-03-24 11:47 Paul Ishenin Status feedback => resolved
2012-03-24 11:47 Paul Ishenin Fixed in Version => 0.9.31 (SVN)
2012-03-24 11:47 Paul Ishenin Resolution open => no change required
2012-03-24 11:47 Paul Ishenin Assigned To => Paul Ishenin
2012-03-24 11:47 Paul Ishenin Note Added: 0057978
2012-03-24 17:34 John Repucci Note Added: 0057986
2012-10-06 05:44 John Repucci Status resolved => closed