View Issue Details

IDProjectCategoryView StatusLast Update
0020139LazarusIDEpublic2011-10-07 18:35
ReporterFlávio Etrusco Assigned ToFlávio Etrusco  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version0.9.31 (SVN) 
Target Version1.2.0 
Summary0020139: Designer: clicking TWinControl-descendant selects TGraphic-descendant on higher z-order
Description1) Add a TButton to a form.
2) Add a TBevel to the form and place it in a way that it "covers" the button (at least partially).
3) Trying to click the button selects the bevel, although the button shows above the bevel.
TagsNo tags attached.
Fixed in Revision
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0019904 acknowledged Form Designer weirdness -- select hidden control, depndent on creation order 

Activities

Flávio Etrusco

2011-09-05 03:42

developer   ~0051454

BTW if this is acknowledged as a bug I can try to make a fix/patch.

Vincent Snijders

2011-10-07 18:26

manager   ~0052750

It was acknowledged as a valid bug report.

Flávio Etrusco

2011-10-07 18:35

developer   ~0052752

Well, one of them (bugs) should be marked duplicate. And since the other one is the oldest...

Issue History

Date Modified Username Field Change
2011-09-02 22:54 Flávio Etrusco New Issue
2011-09-02 22:54 Flávio Etrusco LazTarget => -
2011-09-02 22:54 Flávio Etrusco Widgetset => Win32/Win64
2011-09-05 03:42 Flávio Etrusco Note Added: 0051454
2011-10-07 14:36 Vincent Snijders LazTarget - => 1.2
2011-10-07 14:36 Vincent Snijders Status new => acknowledged
2011-10-07 14:36 Vincent Snijders Target Version => 1.2.0
2011-10-07 17:22 Flávio Etrusco Relationship added duplicate of 0019904
2011-10-07 17:22 Flávio Etrusco Duplicate ID 0 => 19904
2011-10-07 17:22 Flávio Etrusco Status acknowledged => resolved
2011-10-07 17:22 Flávio Etrusco Resolution open => duplicate
2011-10-07 17:22 Flávio Etrusco Assigned To => Flávio Etrusco
2011-10-07 17:26 Flávio Etrusco Description Updated
2011-10-07 18:26 Vincent Snijders Note Added: 0052750
2011-10-07 18:35 Flávio Etrusco Note Added: 0052752