View Issue Details

IDProjectCategoryView StatusLast Update
0020144LazarusLCLpublic2011-09-04 23:18
ReporterAvishaiAssigned ToMaxim Ganetsky 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0020144: Snapshot 0.9.31-32163-fpc-2.5.1-20110903 no longer allows entering Hebrew Text.
DescriptionSnapshot 0.9.31-32163-fpc-2.5.1-20110903 no longer allows entering Hebrew Text. When I switch the keyboard language to Hebrew, I get something like "éÓÒÛéÛ" instead of "אבישי". It was fine before. I do not know if it is Lazarus or FPC. I have gone back to older version for now.
TagsNo tags attached.
Fixed in Revision32173
LazTarget0.99.0
WidgetsetWin32/Win64
Attached Files

Activities

Martin Friebe

2011-09-03 21:12

manager   ~0051425

Which revision is your older version?

Does this apply to:
- SynEdit (the source code editor)
- Any Edit field (e.g the input in the "Search" dialog)
- both?

In order to enter the desired text:
- Do you require the "AltGr" key?
- Is this a sequences of multiply keystrokes (e.g in some languages for accented chars, you first hit the key for the accent, then the key for the char, and it will result in just one accented char)

If it is a sequence (and applies to SynEdit), can you make sure, that the first key, is not assigned in the editor keymapping (options dialog)?

Avishai

2011-09-03 21:37

reporter   ~0051426

The older rev. is 0.9.31-32139-fpc-2.5.1-20110901
The problem was universal in all controls that I tried, but I did not try in SynEdit and I did not try in the IDE. TEdit, TMemo, TComboBox, TStringGrid. My guess is that it is FPC but I do not know. I do not want to reinstall the bad snapshot to investigate. It caused a lot of problems and I do not want to do the fixing again.

Maxim Ganetsky

2011-09-03 22:37

developer   ~0051431

Please test with r32173 or later.

Also, do Hebrew accelerator keys work with this revision?

Avishai

2011-09-03 22:58

reporter   ~0051432

I do not have r32173 or later. How can I get it? I do not have SVN and I am forbidden to install it.

Hebrew accelerator keys do not work. When I try to set CTRL+א in the property editor it gives Key "Unknown" and shortcut is empty.

Maxim Ganetsky

2011-09-03 23:17

developer   ~0051434

You can get it from SVN or wait for tomorrow snapshot.

Accelerator keys are those underlined characters e.g. in Lazarus main menu and are activated by pressing Alt+<underlined char>. Note that you should test in r32173 or later.

Avishai

2011-09-04 07:22

reporter   ~0051441

I do not know who fixed this issue but...THANKYOU, THANKYOU, THANKYOU!!!
Hebrew text is back in Lazarus-0.9.31-32174-fpc-2.5.1-20110904-win64.

Hebrew Accelerator keys never worked in Lazarus so I stopped using them. I just tried it so that I could answer your question. They still do not work. In the Menu Editor it show the underlined Char, but on Run-Time it show no underline and does not execute when you push the keys. Hebrew Shortcut Keys do not work also.

Anyway, I am happy :) All of my programs work again :))

It scared me but, This issue is RESOLVED!

Avishai

2011-09-04 09:54

reporter   ~0051442

Last edited: 2011-09-04 09:55

If you want to test Accelerator Key, you can copy/paste this text,'&אבישי' to the Caption of a menu item. In the menu editor it looks like it will work. You will see the underline. But in Run-Time there is no underline and it does not work. Windows 7

Maxim Ganetsky

2011-09-04 13:06

developer   ~0051445

Last edited: 2011-09-04 13:13

Are you sure that you are pressing Alt-<accelerator key>, not just accelerator key? Accelerator characters get underlined at run-time when you press Alt.

See attached Hebrew_accelerator.png.

2011-09-04 13:13

 

Hebrew_accelerator.png (14,998 bytes)
Hebrew_accelerator.png (14,998 bytes)

Avishai

2011-09-04 13:35

reporter   ~0051446

Last edited: 2011-09-04 13:50

I found the problem. Hebrew Eccelerators work. I had part of the menu in English and part in Hebrew (Multi-Lingual Program). To get to '&File' I have to be in Engish, but then I have to switch to Hebrew (ALT+Shift) to get to '&פתוח'. When I switch languages it closes the menu. Logical, but I did not think about it.

Maxim Ganetsky

2011-09-04 13:40

developer   ~0051447

Last edited: 2011-09-04 13:59

Perfect. Thanks for your prompt feedback.

Issue History

Date Modified Username Field Change
2011-09-03 20:31 Avishai New Issue
2011-09-03 20:31 Avishai Widgetset => Win32/Win64
2011-09-03 21:12 Martin Friebe Note Added: 0051425
2011-09-03 21:37 Avishai Note Added: 0051426
2011-09-03 22:37 Maxim Ganetsky LazTarget => 0.99.0
2011-09-03 22:37 Maxim Ganetsky Note Added: 0051431
2011-09-03 22:37 Maxim Ganetsky Status new => feedback
2011-09-03 22:37 Maxim Ganetsky Target Version => 0.99.0
2011-09-03 22:58 Avishai Note Added: 0051432
2011-09-03 23:17 Maxim Ganetsky Note Added: 0051434
2011-09-04 07:22 Avishai Note Added: 0051441
2011-09-04 09:54 Avishai Note Added: 0051442
2011-09-04 09:55 Avishai Note Edited: 0051442
2011-09-04 13:06 Maxim Ganetsky Note Added: 0051445
2011-09-04 13:13 Maxim Ganetsky File Added: Hebrew_accelerator.png
2011-09-04 13:13 Maxim Ganetsky Note Edited: 0051445
2011-09-04 13:35 Avishai Note Added: 0051446
2011-09-04 13:40 Maxim Ganetsky Fixed in Revision => 32173
2011-09-04 13:40 Maxim Ganetsky Status feedback => resolved
2011-09-04 13:40 Maxim Ganetsky Fixed in Version => 0.9.31 (SVN)
2011-09-04 13:40 Maxim Ganetsky Resolution open => fixed
2011-09-04 13:40 Maxim Ganetsky Assigned To => Maxim Ganetsky
2011-09-04 13:40 Maxim Ganetsky Note Added: 0051447
2011-09-04 13:50 Avishai Note Edited: 0051446
2011-09-04 13:59 Maxim Ganetsky Note Edited: 0051447
2011-09-04 23:18 Avishai Status resolved => closed