View Issue Details

IDProjectCategoryView StatusLast Update
0020189LazarusIDEpublic2011-09-10 00:36
ReporterGraeme Geldenhuys Assigned ToZeljan Rikalo  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSUbuntu Linux 
Product Version0.9.30.1 (SVN) 
Summary0020189: Lazarus Trunk can't enlarge a TButton in the Form Designer
DescriptionSee attached test project. I'm using Lazarus 0.9.31 r32222 FPC 2.4.5 x86_64-linux-gtk 2.

I can't make a button width smaller using the Form Designer by grabbing the resize handles. But I can't seem to increase the width of the button using the resize handles!
TagsNo tags attached.
Fixed in Revision32231
LazTarget0.99.0
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0019702 resolvedZeljan Rikalo can't enlarge edit on a form 
related to 0008178 closedZeljan Rikalo Cant turn off mouse capturing in TWinControl 

Activities

2011-09-08 09:55

 

listbox_test.tar.gz (65,478 bytes)

Mattias Gaertner

2011-09-08 10:18

manager   ~0051582

Very strange.
I tested and I was able to reproduce the bug. But then not any more. Even restarting the IDE and doing everything the same I was not able to reproduce it.
I tried a few times and then once while it starts resizing, suddenly the grab was lost.
This bug may be a tough one.

Felipe Monteiro de Carvalho

2011-09-08 10:24

developer   ~0051583

What would be really useful would be the revision where this issue was introduced, but since the reproduction is not 100%, it will be problematic.

PS: What does listbox_test.tar.gz have to do with this bug?

Graeme Geldenhuys

2011-09-08 10:26

reporter   ~0051584

Most of the times it doesn't work, but just sometimes it does. I've also noticed that when it does work (enlarging the button), the button isn't updated until I release the mouse button.

Graeme Geldenhuys

2011-09-08 10:53

reporter   ~0051586

@Felipe,
It's the project I noticed the problem in. So I wasn't sure if it is a general Form Designer issue, of it is something specific to the project (maybe lfm file) I was working one. So to be on the safe side, I included the project attachment too.

As for the revision that introduced the problem. I haven't really used Trunk since 0.9.30.1 was out. But I am using a local git mirror of Lazarus Trunk, so jumping between revisions (using 'git bisect') shouldn't take too long.

Felipe Monteiro de Carvalho

2011-09-08 11:57

developer   ~0051588

information from the mailling list:

1> It happens in rev32010 so the issue is not new.

2> It reproduces at 100%. It works when you grab the outter half of the grabber. It does not resize when you grab the inner half of the grabber, the half more inside the button.

Felipe Monteiro de Carvalho

2011-09-08 14:19

developer   ~0051595

I got the following results so far:

29900 - works
30000 - IDE crashes at startup
31000 - doesnt work
32000 - cant test, broken IDE
32010 - doesnt work

Felipe Monteiro de Carvalho

2011-09-08 14:41

developer   ~0051597

30100 - works
30150 - works
30151 - works
30152 - doesnt work
30155 - doesnt work
30160 - doesnt work
30170 - doesnt work
30175 - doesnt work
30200 - doesnt work
30250 - doesnt work

http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=rev&root=lazarus&revision=30152

Felipe Monteiro de Carvalho

2011-09-08 14:41

developer   ~0051598

Revision 30152 - (view) (download) (annotate) - [select for diffs]
Modified Sun Apr 3 13:32:40 2011 UTC (5 months ago) by zeljko
File length: 105935 byte(s)
Diff to previous 29837
Gtk2: bugfix where csCaptureMouse cannot be disabled. issue 0008178

Graeme Geldenhuys

2011-09-08 15:11

reporter   ~0051600

Thanks Felipe, I was going to search for it in my lunch hour, but you beat me to it. :) Amazing that the LCL-GTK2 form designer was broken for 5 months without anybody noticing or mentioning something. Maybe nobody uses LCL-GTK2 any more. :-)

Alexsander

2011-09-08 15:37

reporter   ~0051606

> Maybe nobody uses LCL-GTK2 any more. :-)

I would say "nobody uses LCL-GTK2 from SVN anymore". I'm sure there's a large group of developers using LCL-GTK2 with stable releases (like 0.9.30). I'm one of them.

Zeljan Rikalo

2011-09-08 15:45

developer   ~0051608

Please test and close if ok.

Issue History

Date Modified Username Field Change
2011-09-08 09:55 Graeme Geldenhuys New Issue
2011-09-08 09:55 Graeme Geldenhuys File Added: listbox_test.tar.gz
2011-09-08 09:55 Graeme Geldenhuys Widgetset => GTK 2
2011-09-08 10:18 Mattias Gaertner Note Added: 0051582
2011-09-08 10:24 Felipe Monteiro de Carvalho Note Added: 0051583
2011-09-08 10:26 Graeme Geldenhuys Note Added: 0051584
2011-09-08 10:53 Graeme Geldenhuys Note Added: 0051586
2011-09-08 11:57 Felipe Monteiro de Carvalho Note Added: 0051588
2011-09-08 14:19 Felipe Monteiro de Carvalho Note Added: 0051595
2011-09-08 14:41 Felipe Monteiro de Carvalho Note Added: 0051597
2011-09-08 14:41 Felipe Monteiro de Carvalho Note Added: 0051598
2011-09-08 14:42 Felipe Monteiro de Carvalho LazTarget => 0.99.0
2011-09-08 14:42 Felipe Monteiro de Carvalho Status new => confirmed
2011-09-08 14:42 Felipe Monteiro de Carvalho Relationship added related to 0008178
2011-09-08 15:11 Graeme Geldenhuys Note Added: 0051600
2011-09-08 15:37 Alexsander Note Added: 0051606
2011-09-08 15:45 Zeljan Rikalo Fixed in Revision => 32231
2011-09-08 15:45 Zeljan Rikalo Status confirmed => resolved
2011-09-08 15:45 Zeljan Rikalo Resolution open => fixed
2011-09-08 15:45 Zeljan Rikalo Assigned To => Zeljan Rikalo
2011-09-08 15:45 Zeljan Rikalo Note Added: 0051608
2011-09-10 00:36 Juha Manninen Relationship added duplicate of 0019702