View Issue Details

IDProjectCategoryView StatusLast Update
0020190LazarusDebuggerpublic2011-09-08 12:54
ReporterGraeme GeldenhuysAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSUbuntu LinuxOS Version10.04
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0020190: Debug tooltip info on Sender is slow and overwhelming
DescriptionSee attached screenshot. I set a breakpoint inside a method, then did a debug tooltip hint over the Sender method parameter. On my 2.6Ghz Quad Core, it took about 7 seconds to display the tooltip hint.

And when it displayed, I saw that HUGE tooltip which really doesn't help much. There is too much information, and the tooltip doesn't actually fit inside the screen space.

I'm using Lazarus 0.9.31 r32222 FPC 2.4.5 x86_64-linux-gtk 2.
TagsNo tags attached.
Fixed in Revision32226
LazTarget0.99.0
Widgetset
Attached Files

Relationships

related to 0020196 closedJuha Manninen GTK2, very slow hint for very long line 

Activities

2011-09-08 10:09

 

Screenshot.png (112,667 bytes)
Screenshot.png (112,667 bytes)

2011-09-08 12:28

 

laz_stable.png (6,269 bytes)
laz_stable.png (6,269 bytes)

Graeme Geldenhuys

2011-09-08 12:31

reporter   ~0051589

I just attached another screenshot showing how it looks like in Lazarus 0.9.30.1 r30567M FPC 2.4.5 x86_64-linux-gtk 2. It also shows the full method signature.

In Lazarus (stable), the tooltip info appears instantly (when the tooltip is supposed to trigger - after a 500ms hover) - no delay.

Martin Friebe

2011-09-08 12:32

manager   ~0051590

Implemented an options (Editor / Completion and Hints) to disable the auto typecast.

Please test and close if ok.


Unfortunately this report is not clear to which issue it refers:
- New auto type cast is slow
- IDE hint windows (both: debug or help) have no size limit ("overwhelming")

If the 2nd point remains an issue, you may check if it is already reported, or report it yourself in a separate issue.

Graeme Geldenhuys

2011-09-08 12:54

reporter   ~0051592

My concern is the slowness of displaying the debug tooltip. 7 seconds is excessive. Simply saying disabling it, fixes the problem doesn't seem right. Why is it so slow in the first place?

Issue History

Date Modified Username Field Change
2011-09-08 10:09 Graeme Geldenhuys New Issue
2011-09-08 10:09 Graeme Geldenhuys Status new => assigned
2011-09-08 10:09 Graeme Geldenhuys Assigned To => Marc Weustink
2011-09-08 10:09 Graeme Geldenhuys File Added: Screenshot.png
2011-09-08 11:48 Martin Friebe Assigned To Marc Weustink => Martin Friebe
2011-09-08 12:28 Graeme Geldenhuys File Added: laz_stable.png
2011-09-08 12:31 Graeme Geldenhuys Note Added: 0051589
2011-09-08 12:32 Martin Friebe Fixed in Revision => 32226
2011-09-08 12:32 Martin Friebe LazTarget => 0.99.0
2011-09-08 12:32 Martin Friebe Status assigned => resolved
2011-09-08 12:32 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2011-09-08 12:32 Martin Friebe Resolution open => fixed
2011-09-08 12:32 Martin Friebe Note Added: 0051590
2011-09-08 12:33 Martin Friebe Target Version => 0.99.0
2011-09-08 12:54 Graeme Geldenhuys Note Added: 0051592
2011-09-08 19:10 Vincent Snijders Relationship added related to 0020196