View Issue Details

IDProjectCategoryView StatusLast Update
0020196LazarusWidgetsetpublic2019-04-22 19:33
ReporterMartin FriebeAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version0.9.31 (SVN)Product Build 
Target Version1.4Fixed in Version 
Summary0020196: GTK2, very slow hint for very long line
DescriptionIf the IDE (without html hint / without TurboPowerPro[Dsgn]) has to display a hint, that consist of one single very long line (such as returned by GDB for a large class) then gtk2 may take several seconds to display this hint (presumingly wordwrapping?)

In order to reproduce:
- create a new application
  TForm1 = class)TForm)
- go to declaration of TForm, and enter on the line immediately before "TForm = Class(TCustomForm)", a single line comment of 10.000 chars
- No go back to unit1, and have a hint for TForm (not TForm1)

The required length of the line, and the time experience seem to differ from system to system.

On the same CPU running GTK2 on w32 => it is all very fast.
Running GTK2 in Fedora => 10000 chars might take forever.

This also caused the report 0020190 (see notes)

TagsNo tags attached.
Fixed in Revision
LazTarget1.4
WidgetsetGTK 2
Attached Files

Relationships

related to 0020190 resolvedMartin Friebe Debug tooltip info on Sender is slow and overwhelming 

Activities

Juha Manninen

2014-09-10 10:33

developer   ~0077028

This is irrelevant now because iPro is installed and renders HTML by default.
Resolving...

Issue History

Date Modified Username Field Change
2011-09-08 18:44 Martin Friebe New Issue
2011-09-08 18:44 Martin Friebe LazTarget => -
2011-09-08 18:44 Martin Friebe Widgetset => GTK 2
2011-09-08 19:10 Vincent Snijders Relationship added related to 0020190
2011-10-07 14:44 Vincent Snijders LazTarget - => 1.2
2011-10-07 14:44 Vincent Snijders Status new => acknowledged
2011-10-07 14:44 Vincent Snijders Target Version => 1.2.0
2014-01-14 15:10 Martin Friebe LazTarget 1.2 => 1.4
2014-01-14 15:12 Martin Friebe Target Version 1.2.0 => 1.4
2014-09-10 10:32 Juha Manninen Assigned To => Juha Manninen
2014-09-10 10:32 Juha Manninen Status acknowledged => assigned
2014-09-10 10:33 Juha Manninen Note Added: 0077028
2014-09-10 10:33 Juha Manninen Status assigned => resolved
2014-09-10 10:33 Juha Manninen Resolution open => won't fix
2019-04-22 19:33 Martin Friebe Status resolved => closed