View Issue Details

IDProjectCategoryView StatusLast Update
0020229LazarusLCLpublic2011-10-20 22:48
ReportermalcomeAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0020229: ExpandFileNameUTF8, ExpandUNCFileNameUTF8 or other UTF8 functions in FileUtil
DescriptionUTF8 functions in FileUtil do not operate correctly.
See attached files.

Please do not use UTF8ToAnsi(UTF8ToSys). ANSI cannot express all of Unicode.
 
TagsNo tags attached.
Fixed in Revision33000
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

2011-09-13 09:48

 

UTF8.zip (2,355 bytes)

malcome

2011-09-14 04:21

reporter   ~0051803

The reply from the manager or developer who is not knowledgeable about Unicode is unnecessary.
Since I feel unpleasant repeatedly.

Felipe Monteiro de Carvalho

2011-10-20 22:02

developer   ~0053218

Last edited: 2011-10-20 22:11

I do appreciate that you created a very nice test case which demonstes the problem very well.

I am amazed that the problem affects Mac OS X as well. FileExistsUTF8 simply uses SysUtils.FileExists and this fails for that wierd filename in Mac OS X =O really strange. Maybe this is related to the decomposition of UTF-8 done by Mac OS X. So we need to implement a decomposition routine to fix this, which might be a complex tax.

It should be easy to fix this in Windows since it only requires calling the appropriate Windows APIs.

Felipe Monteiro de Carvalho

2011-10-20 22:48

developer   ~0053219

I fixed the Windows problems from your test project

Issue History

Date Modified Username Field Change
2011-09-13 09:48 malcome New Issue
2011-09-13 09:48 malcome File Added: UTF8.zip
2011-09-13 09:48 malcome Widgetset => Win32/Win64
2011-09-14 04:21 malcome Note Added: 0051803
2011-10-07 14:56 Vincent Snijders LazTarget => -
2011-10-07 14:56 Vincent Snijders Assigned To => Felipe Monteiro de Carvalho
2011-10-07 14:56 Vincent Snijders Status new => assigned
2011-10-20 22:02 Felipe Monteiro de Carvalho Note Added: 0053218
2011-10-20 22:11 Felipe Monteiro de Carvalho Note Edited: 0053218
2011-10-20 22:48 Felipe Monteiro de Carvalho Fixed in Revision => 33000
2011-10-20 22:48 Felipe Monteiro de Carvalho Status assigned => resolved
2011-10-20 22:48 Felipe Monteiro de Carvalho Fixed in Version => 0.9.31 (SVN)
2011-10-20 22:48 Felipe Monteiro de Carvalho Resolution open => fixed
2011-10-20 22:48 Felipe Monteiro de Carvalho Note Added: 0053219