View Issue Details

IDProjectCategoryView StatusLast Update
0020236LazarusIDEpublic2020-01-28 22:57
ReporterFlávio EtruscoAssigned ToMattias Gaertner 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version 
Summary0020236: CodeTools: block-completion doesn't understand IFDEF blocks (places 'end;' after '{$ENDIF} block)
Description1) Write an IFDEF block with closing ENDIF;
2) Write code inside the block;
3) Upon begin-completion (press Return after 'begin') the 'end;' is written after the ENDIF.

{$IFDEF SafeAssignment}
  if FCanary <> @Self then
  begin|

{$ENDIF}
  end;

4) Chaning the IFDEF and ENDIF indention to the same level or below the code doesn't make a difference.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0019271 assignedMattias Gaertner Procedure Completion creates procedure body in trailing {$IFDEF} block 
has duplicate 0021316 closedMattias Gaertner Code completion and conditional compilation 
has duplicate 0023401 resolvedJuha Manninen Complete Blocks and $IFDEF Bug 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2011-09-14 07:36 Flávio Etrusco New Issue
2011-09-14 07:36 Flávio Etrusco LazTarget => -
2011-09-14 10:00 Mattias Gaertner Status new => assigned
2011-09-14 10:00 Mattias Gaertner Assigned To => Mattias Gaertner
2013-05-02 14:02 Juha Manninen Relationship added duplicate of 0019271
2013-05-03 01:04 Juha Manninen Relationship added has duplicate 0021316
2013-05-16 11:58 Martin Friebe Relationship added has duplicate 0023401
2020-01-28 22:57 Flávio Etrusco Status assigned => resolved
2020-01-28 22:57 Flávio Etrusco Resolution open => fixed