View Issue Details

IDProjectCategoryView StatusLast Update
0020244LazarusIDEpublic2011-09-20 17:10
ReporterlainzAssigned ToJuha Manninen 
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
Platformi386OSWindowsOS Version7
Product Version0.9.31 (SVN)Product Build32323 
Target VersionFixed in Version 
Summary0020244: Lazarus GUI issues in Windows running in High DPI
DescriptionWhen running in Windows High DPI modes the:
* version info labels are one over the other
* new package options > description > version labels are below tspinedit
* lazarus build modes tdividerbevel is clipped

I've reported a similar bug before and was solved changing an anchor:
http://bugs.freepascal.org/view.php?id=19950
TagsHighDPI
Fixed in Revisionr32363, r32422, r32428
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0017929 closedVincent Snijders Control.ScaleBy issues using to scale Form to use in high dpi modes. 
related to 0018233 closedJuha Manninen ScaleDPI: unit for making Windows 7 High DPI Applications 

Activities

2011-09-14 17:19

 

versioninfo.JPG (101,068 bytes)
versioninfo.JPG (101,068 bytes)

2011-09-14 17:20

 

newpackage.JPG (84,470 bytes)
newpackage.JPG (84,470 bytes)

2011-09-14 17:20

 

buildmodes.JPG (82,425 bytes)
buildmodes.JPG (82,425 bytes)

Juha Manninen

2011-09-16 11:12

developer   ~0051908

Please test.

lainz

2011-09-17 03:42

reporter   ~0051931

That's ok.

Only this left:
* lazarus build modes tdividerbevel is clipped

Tools > Configure Build Lazarus > 'Common Settings' (TDividerBevel)

Juha Manninen

2011-09-17 08:48

developer   ~0051940

I improved it in r32375. Please try again.

lainz

2011-09-17 15:18

reporter   ~0051945

That doesn't works: only enlarge the space between the checkboxes and the bottom buttons.

BuildLazDialog

CommonsDividerBevel.AutoSize := True

And that works. So change that property and the bug is solved.

Juha Manninen

2011-09-17 17:39

developer   ~0051952

Done.

lainz

2011-09-17 22:11

reporter   ~0051966

Thankyou.

One thing left can be enable the option 'Dpi Aware application (for Vista +)' for the Lazarus project in Project options (it only changes the manifest).

Also you can close this old bug, is about doing Lazarus HighDPI aware application, with this fixes is being achieved
http://bugs.freepascal.org/view.php?id=18233

All other related HighDPI issues are tagged with 'HighDPI'
http://bugs.freepascal.org/tag_view_page.php?tag_id=286

If I found some other issue I will post it.

Vincent Snijders

2011-09-19 16:00

manager   ~0052029

Updating the .lpi is not enough, I think. Those changes need to be propagated into the lazarus.res to be effective.

Juha Manninen

2011-09-19 23:10

developer   ~0052046

I committed lazarus.res at r32428. Is it good?

lainz

2011-09-20 04:05

reporter   ~0052054

It's good.

I forget this bug:
http://bugs.freepascal.org/view.php?id=17929

Is not a bug, because ScaleBy uses right Delphi behavior, to dpi is better to use your own scaling procedure (like ScaleDPI in the wiki article) or use the AutoSize option (like most of this bug patches).

Issue History

Date Modified Username Field Change
2011-09-14 17:19 lainz New Issue
2011-09-14 17:19 lainz Widgetset => Win32/Win64
2011-09-14 17:19 lainz Tag Attached: HighDPI
2011-09-14 17:19 lainz File Added: versioninfo.JPG
2011-09-14 17:20 lainz File Added: newpackage.JPG
2011-09-14 17:20 lainz File Added: buildmodes.JPG
2011-09-16 11:02 Juha Manninen Status new => assigned
2011-09-16 11:02 Juha Manninen Assigned To => Juha Manninen
2011-09-16 11:12 Juha Manninen Fixed in Revision => r32363
2011-09-16 11:12 Juha Manninen LazTarget => -
2011-09-16 11:12 Juha Manninen Status assigned => resolved
2011-09-16 11:12 Juha Manninen Resolution open => fixed
2011-09-16 11:12 Juha Manninen Note Added: 0051908
2011-09-17 03:42 lainz Note Added: 0051931
2011-09-17 08:48 Juha Manninen Status resolved => assigned
2011-09-17 08:48 Juha Manninen Resolution fixed => reopened
2011-09-17 08:48 Juha Manninen Note Added: 0051940
2011-09-17 08:49 Juha Manninen Status assigned => feedback
2011-09-17 15:18 lainz Note Added: 0051945
2011-09-17 17:39 Juha Manninen Status feedback => resolved
2011-09-17 17:39 Juha Manninen Resolution reopened => fixed
2011-09-17 17:39 Juha Manninen Note Added: 0051952
2011-09-17 22:11 lainz Note Added: 0051966
2011-09-19 04:11 lainz Status resolved => closed
2011-09-19 09:55 Juha Manninen Relationship added related to 0018233
2011-09-19 16:00 Vincent Snijders Note Added: 0052029
2011-09-19 16:01 Vincent Snijders Status closed => assigned
2011-09-19 16:01 Vincent Snijders Resolution fixed => reopened
2011-09-19 23:10 Juha Manninen Note Added: 0052046
2011-09-20 04:05 lainz Note Added: 0052054
2011-09-20 09:14 Juha Manninen Relationship added related to 0017929
2011-09-20 09:22 Juha Manninen Fixed in Revision r32363 => r32363, r32422, r32428
2011-09-20 09:22 Juha Manninen Status assigned => resolved
2011-09-20 09:22 Juha Manninen Resolution reopened => fixed
2011-09-20 17:10 lainz Status resolved => closed