View Issue Details

IDProjectCategoryView StatusLast Update
0020263LazarusIDEpublic2011-09-16 09:25
ReporterLudo BrandsAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.30.1 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0020263: CodeTools: incorrect auto-indent when pasting code over old code
DescriptionWhen pasting code over old code (select a block and paste in new block) the original indentation is kept. Delete old code then paste new code works.
Select source, Ctrl-C, select destination to be replaced, Ctrl-V doesn't work.
Select source, Ctrl-C, select destination to be replaced, Del, Ctrl-V does work.
TagsNo tags attached.
Fixed in Revision32361
LazTarget0.99.0
WidgetsetWin32/Win64
Attached Files

Activities

Mattias Gaertner

2011-09-15 20:32

manager   ~0051873

Martin:
Auto indent is skipped when SyncroLockCount>0.
It seems this is active not only when syncro editing - as the name implies - but in general when text is selected.
Is this by design?

Martin Friebe

2011-09-15 23:37

manager   ~0051888

Fixed, please close if ok.

Note, if the editor is in syncro edit mode, no indent will be done. This includes, if you paste outside the cells, which will end the syncro mode. (This is because at the time of the paste, syncro is still active)

Ludo Brands

2011-09-16 09:25

developer   ~0051902

Thanks, solved

Issue History

Date Modified Username Field Change
2011-09-15 19:17 Ludo Brands New Issue
2011-09-15 19:17 Ludo Brands Widgetset => Win32/Win64
2011-09-15 20:29 Mattias Gaertner Status new => assigned
2011-09-15 20:29 Mattias Gaertner Assigned To => Martin Friebe
2011-09-15 20:32 Mattias Gaertner Note Added: 0051873
2011-09-15 23:37 Martin Friebe Fixed in Revision => 32361
2011-09-15 23:37 Martin Friebe LazTarget => 0.99.0
2011-09-15 23:37 Martin Friebe Status assigned => resolved
2011-09-15 23:37 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2011-09-15 23:37 Martin Friebe Resolution open => fixed
2011-09-15 23:37 Martin Friebe Note Added: 0051888
2011-09-15 23:37 Martin Friebe Target Version => 0.99.0
2011-09-16 09:25 Ludo Brands Status resolved => closed
2011-09-16 09:25 Ludo Brands Note Added: 0051902