View Issue Details

IDProjectCategoryView StatusLast Update
0020293LazarusIDEpublic2013-05-31 08:06
ReporterJason Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version0.9.31 (SVN) 
Target Version1.2.0 
Summary0020293: Tooltips of the components are not wide enough in both directions to show the whole messege.
DescriptionI am using lazarus 0.9.31 svn 32373 with fpc 2.7.1.My os is windows 7 x64.
TagsNo tags attached.
Fixed in Revision
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0022851 resolvedPaul Ishenin Hint for component on component palette is not completely visible 

Activities

Flávio Etrusco

2011-09-19 06:45

developer   ~0052008

I can't reproduce the problem on Win7 32-bit.
No Win64 here, but this doesn't look like a 32 vs 64bit issue, so I guess any developer could use:
1) A concrete example component or attached project. (does it happen on a clean project with a TButton?)
2) Any non-standard Windows setting (resolution, DPI, Theme/fonts, video card, window manager add-ons)

Jason

2011-09-20 03:46

reporter   ~0052053

Last edited: 2011-09-20 04:57

It's the problem of conponent's hint.May be it only happens on a Chinese Windows 7 x64 system.I switched to English of the OS's language,the hints were displayed correctly.

Flávio Etrusco

2011-09-20 05:35

developer   ~0052055

Last edited: 2011-09-20 05:37

Oh, I forgot to ask for this: a screenshot. Yes, the problem is most certainly related to wide/double-width Chinese chars then. A screenshot (PrintScreen) is still welcome ;)

2011-09-21 14:05

 

SnapShot.7z (83,258 bytes)

Jason

2011-09-21 14:06

reporter   ~0052082

Hi,Flávio Etrusco,I'v uploaded two snapshots.

Zeljan Rikalo

2012-02-04 14:11

developer   ~0056436

Not blocker, postponed.

samuel herzog

2013-01-01 13:41

developer   ~0064563

Please re-test. For me the hints look Ok. (But I have no chinese windows)

Tested today with: Lazarus 1.1 r39026 FPC 2.6.1 i386-win32-win32/win64

Juha Manninen

2013-05-31 08:06

developer   ~0067949

Resolving as duplicate.

Issue History

Date Modified Username Field Change
2011-09-19 04:38 Jason New Issue
2011-09-19 06:45 Flávio Etrusco Note Added: 0052008
2011-09-20 03:46 Jason Note Added: 0052053
2011-09-20 04:57 Jason Note Edited: 0052053
2011-09-20 05:35 Flávio Etrusco Note Added: 0052055
2011-09-20 05:37 Flávio Etrusco Note Edited: 0052055
2011-09-21 14:05 Jason File Added: SnapShot.7z
2011-09-21 14:06 Jason Note Added: 0052082
2011-10-07 15:13 Vincent Snijders LazTarget => 1.0
2011-10-07 15:13 Vincent Snijders Status new => acknowledged
2011-10-07 15:13 Vincent Snijders Target Version => 1.0.0
2012-02-04 14:11 Zeljan Rikalo LazTarget 1.0 => 1.2
2012-02-04 14:11 Zeljan Rikalo Note Added: 0056436
2012-03-13 07:50 Vincent Snijders Target Version 1.0.0 => 1.2.0
2012-09-10 21:02 Juha Manninen Relationship added has duplicate 0022851
2012-09-10 21:02 Juha Manninen Widgetset => Win32/Win64
2013-01-01 13:41 samuel herzog Note Added: 0064563
2013-05-31 08:06 Juha Manninen Note Added: 0067949
2013-05-31 08:06 Juha Manninen Relationship replaced duplicate of 0022851
2013-05-31 08:06 Juha Manninen Status acknowledged => resolved
2013-05-31 08:06 Juha Manninen Resolution open => duplicate
2013-05-31 08:06 Juha Manninen Assigned To => Juha Manninen