View Issue Details

IDProjectCategoryView StatusLast Update
0002040Lazarus-public2012-01-11 05:08
ReporterJonas JasasAssigned ToMartin Friebe 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSKubuntuOS Version5.10
Product Version0.9.14Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0002040: Feature like in Delphi in debug mode pressing Ctrl+click on class
DescriptionIt is very usefull feature in Delphi, Ctrl+click on class (or any variable) in text editor (debug mode) shows structure of the current class instance with data assigned to properties. Would be very usefull to have this feature in Lazarus.
TagsNo tags attached.
Fixed in Revision34704
LazTarget1.0
Widgetset
Attached Files

Relationships

related to 0015499 resolvedMarc Weustink Scarce information in Debug Inspector 

Activities

Matthijs Willemstein

2006-05-01 04:05

reporter   ~0002811

In Delphi it is called "Debug Inspector". It does show the properties (data) and methods.

Zeljan Rikalo

2012-01-09 17:14

developer   ~0055630

Isn't this implemented in current trunk ? eg. 34683

Martin Friebe

2012-01-09 19:11

manager   ~0055633

Last edited: 2012-01-09 19:14

The debug inspetor exists, yes. It still misses a few things (embedded objects, filter, sort, ...), but that's 0015499
---

It is only reachable via key-shortcut or menu.
There is no mouse click.

Ctrl-left is used by code navigation, and since this keeps working while debugging (and is equally useful while debugging), it should not be used for this.

Other mouse clicks could be used. Though I am not sure this feature is important enough. Equally an "add to watches" / "watchpoint" click may be interesting.

There are plans to allow hints (dbg-eval-hint) to have click-able content, it could go there.

Currently this can be added in *advanced* mouse options.

---

I will add it to the normal config too.
However it will have to use a different modifier key as ctrl is used.

Martin Friebe

2012-01-11 05:08

manager   ~0055666

Implemented an option to open a debug specific popup. This allows to inspect, watch, ...

It is not assigned by default, you can assign it to any mouse-click (incl shift/ctrl) in the normal mouse options

Issue History

Date Modified Username Field Change
2006-05-01 02:40 Jonas Jasas New Issue
2006-05-01 02:40 Jonas Jasas Widgetset => GTK
2006-05-01 04:05 Matthijs Willemstein Target => post 1.0
2006-05-01 04:05 Matthijs Willemstein Note Added: 0002811
2006-05-01 04:05 Matthijs Willemstein Status new => acknowledged
2011-09-09 16:03 Martin Friebe Relationship added related to 0015499
2012-01-09 17:14 Zeljan Rikalo LazTarget post 1.0 => -
2012-01-09 17:14 Zeljan Rikalo Note Added: 0055630
2012-01-09 17:14 Zeljan Rikalo Status acknowledged => feedback
2012-01-09 19:09 Martin Friebe Status feedback => assigned
2012-01-09 19:09 Martin Friebe Assigned To => Martin Friebe
2012-01-09 19:11 Martin Friebe LazTarget - => 1.0
2012-01-09 19:11 Martin Friebe Widgetset GTK =>
2012-01-09 19:11 Martin Friebe Note Added: 0055633
2012-01-09 19:12 Martin Friebe Note Edited: 0055633
2012-01-09 19:14 Martin Friebe Note Edited: 0055633
2012-01-11 05:08 Martin Friebe Fixed in Revision => 34704
2012-01-11 05:08 Martin Friebe Status assigned => resolved
2012-01-11 05:08 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2012-01-11 05:08 Martin Friebe Resolution open => fixed
2012-01-11 05:08 Martin Friebe Note Added: 0055666
2012-01-11 05:08 Martin Friebe Target Version => 0.99.0