View Issue Details

IDProjectCategoryView StatusLast Update
0020401LazarusOtherpublic2012-05-15 16:56
ReporterJD Assigned ToAbou Al Montacir  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN) 
Summary0020401: Lazarus on Linux is missing files that are found in Lazarus on Windows
DescriptionI'm using Lazarus 0.9.31/FPC 2.4.4 svn 31847 on Linux Mint 11, Ubuntu 11.04, Windows XP and Windows Vista.

Over time, I have noticed that my Lazarus installation on Linux is missing many files compared with my Lazarus installation on Windows. Sometimes I've had to copy entire folders from Windows to Linux.

For example, the following folders are almost empty in the Linux version:
a) /usr/lib/lazarus/0.9.31/docs/
b) /usr/lib/lazarus/0.9.31/images/

In addition, I had noticed that in the "Components" directory (/usr/lib/lazarus/0.9.31/components/) many of the components are missing the package (lpk) files. I've had to copy them over from the Windows version of Lazarus or recreate them on the Linux side. Some of the lpk files that exist on the Linux side do not work because they were not saved with Unix EOF format. I had to do it all over again! :o

Finally, some default components on the Windows side are not installed by default on the Linux side. This is the case with TChart.

All in all, I've discovered that it helps to have a Windows installation to accompany my Linux installation.

I guess I shouldn't complain too much since it is an svn version. I just hope the official releases don't have such problems.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

has duplicate 0019216 resolvedAbou Al Montacir deb source package is incomplete 

Activities

Vincent Snijders

2011-10-03 20:28

manager   ~0052467

How did you install on linux?

JD

2011-10-03 23:19

reporter   ~0052473

Last edited: 2011-10-04 20:28

I downloaded the Freepascal 2.4.4 and the Lazarus 0.9.31 deb files from Lazarus Snapshots SVN site.

After extracting each file to different directories, I then installed Freepascal and Lazarus in that order by using the sudo dpkg -i * command at the terminal in each of the directories.

Vincent Snijders

2011-10-04 06:35

manager   ~0052482

The deb packages are maintained by Abou and he decides what comes into it, So this is a question for him.

JD

2011-10-04 20:29

reporter   ~0052523

OK. I hope Abou reads the bugtracker often. Thanks.

Abou Al Montacir

2012-03-12 22:43

developer   ~0057534

The docs subdirectory is not installed in /usr/lib/lazarus/${VERSION} because it is installed in /usr/share/doc/lazarus/${VERSION}. This change is made to be conform to Debian policy for documentation.

The helps system is configured to find the help files in the new location using the configuration file /etc/lazarus.

What are you missing in the images subdirectory?

Abou Al Montacir

2012-05-15 16:55

developer   ~0059621

No feedback from user for long time, please reopen if not fixed yet.

Issue History

Date Modified Username Field Change
2011-10-03 20:09 JD New Issue
2011-10-03 20:09 JD Widgetset => GTK 2
2011-10-03 20:28 Vincent Snijders LazTarget => -
2011-10-03 20:28 Vincent Snijders Note Added: 0052467
2011-10-03 20:28 Vincent Snijders Status new => feedback
2011-10-03 23:19 JD Note Added: 0052473
2011-10-03 23:20 JD Note Edited: 0052473
2011-10-03 23:21 JD Note Edited: 0052473
2011-10-04 06:35 Vincent Snijders Note Added: 0052482
2011-10-04 06:35 Vincent Snijders Assigned To => Abou Al Montacir
2011-10-04 06:35 Vincent Snijders Status feedback => assigned
2011-10-04 20:28 JD Note Edited: 0052473
2011-10-04 20:29 JD Note Added: 0052523
2011-10-05 15:23 Vincent Snijders Relationship added has duplicate 0019216
2012-03-12 22:43 Abou Al Montacir Note Added: 0057534
2012-03-12 22:44 Abou Al Montacir Status assigned => feedback
2012-05-15 16:55 Abou Al Montacir Status feedback => resolved
2012-05-15 16:55 Abou Al Montacir Resolution open => fixed
2012-05-15 16:55 Abou Al Montacir Note Added: 0059621